Polyspace® Code Prover™ Release Notes

)\

MATLAB&SIMULINK

> } MathWorks:



X B

How to Contact MathWorks

Latest news: www . mathworks .com

Sales and services: www.mathworks.com/sales_and_services
User community: www . mathworks .com/matlabcentral
Technical support: www . mathworks.com/support/contact_us
Phone: 508-647-7000

The MathWorks, Inc.
3 Apple Hill Drive
Natick, MA 01760-2098

Polyspace® Code Prover™ Release Notes

© COPYRIGHT 2013-2016 by The MathWorks, Inc.

The software described in this document is furnished under a license agreement. The software may be used

or copied only under the terms of the license agreement. No part of this manual may be photocopied or
reproduced in any form without prior written consent from The MathWorks, Inc.

FEDERAL ACQUISITION: This provision applies to all acquisitions of the Program and Documentation
by, for, or through the federal government of the United States. By accepting delivery of the Program
or Documentation, the government hereby agrees that this software or documentation qualifies as
commercial computer software or commercial computer software documentation as such terms are used
or defined in FAR 12.212, DFARS Part 227.72, and DFARS 252.227-7014. Accordingly, the terms and
conditions of this Agreement and only those rights specified in this Agreement, shall pertain to and
govern the use, modification, reproduction, release, performance, display, and disclosure of the Program
and Documentation by the federal government (or other entity acquiring for or through the federal
government) and shall supersede any conflicting contractual terms or conditions. If this License fails

to meet the government's needs or is inconsistent in any respect with federal procurement law, the
government agrees to return the Program and Documentation, unused, to The MathWorks, Inc.

Trademarks

MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See
www . mathworks . com/trademarks for a list of additional trademarks. Other product or brand
names may be trademarks or registered trademarks of their respective holders.

Patents

MathWorks products are protected by one or more U.S. patents. Please see
www . mathworks . com/patents for more information.


www.mathworks.com
www.mathworks.com/sales_and_services
www.mathworks.com/matlabcentral
www.mathworks.com/support/contact_us
http://www.mathworks.com/trademarks
http://www.mathworks.com/patents

Contents

R2016a

Files to Review: Generate results for only specified files and
folders . . ... ... . . . 1-2

Autocompletion for Review Comments: Partially type
previous comment to select complete comment ........ 1-2

Faster MISRA Rule Checking: Check coding rules more
quickly and efficiently ............................. 1-3

S-Function Analysis: Launch analysis of S-Function code
from Simulink . . ....... ... .. 1-3

Persistent Filter States: Apply filters once and view filtered
results across multiple runs ... ...................... 1-3

Floating-Point Support: Propagate ranges more precisely for
long double variables and enable verification mode to

incorporate infinitiesand NaNs ..................... 14
Long Doubles .. ........ ... .. . . . . . 14
Nonfinites in floating-point arithmetic ................. 1-5
Rounding modes . ........ ... ... .. ... .. .. . .. ... 1-6

Polyspace Metrics Tomcat Upgrade: Use upgraded default
Tomecat server or custom Tomecat version ............. 1-7

Updated Polyspace Metrics Interface: View summary of
project and metrics .. ........... .. .. ... 1-7

Project Language Flexibility: Change your project language
at any time . . ... ... ... ... 1-7

iii



iv

Contents

External Constraint on Pointers: Specify certain
initialization with full range for pointer arguments and
return values of stubbed functions ...................

Improved Result Display for File-by-File Verification: View
combined summary of results for all files in user

interface ... ... ... ... ... e

Source Code Search: Search large applications more
quickly . ...

Default Layouts: Switch easily between project setup and
results review in user interface .....................

Simplified Variable Access: View task names instead of
aliases ... ... ...

Polyspace TargetLink plug-in supports data from
structures . ....... ... ...

Polyspace Eclipse plug-in results location moved ........

Improvements in automatic project creation from build
command ........ ... ..

Improvements in checking of previously supported MISRA C

rules . ...
MISRA C:2004 Rules . ......... ... .. . .
MISRA C:2012 Rules . ......... ... . i .

Absolute address usage valid by default ...............
Variables with constraints not counted as orange sources .
Changes in analysis options .. ........................

Run-time checks renamed ...........................

1-9

1-10

1-10

1-10

1-10

1-10

1-11

1-12
1-12
1-12
1-13
1-13
1-14

1-16



R2015b

Option to Suppress Non-initialization Checks: Customize
verification by suppressing non-initialization checks . ..

Improved Concurrency Detection: View more precise sharing
and protection results based on dynamic information such
as data flow in branching statements and protection on
individual fields of a structure ......................

Data Flow in Branch Statements .....................
Shared Structures ............ ... ...

Microsoft Visual C++ 2013 Support: Analyze code developed
in Microsoft Visual C++ 2013 ... .....................

Additional MISRA C:2012 Support: Detect violations of all
MISRA C:2012 rules except rules 22.x .. ...............

GNU 4.9 and Clang 3.5 Support: Analyze code compiled with
GCC49o0r Clang 3.5 . ... ... ... ... ...

Improved Review Capability: View result details and add
review comments in one window ....................

Saved Layouts: Save your preferred layouts of the Polyspace
user interface . ........ ... ... . ... . ... ...

Autodetection of Multitasking Primitives: Analyze source
code with multitasking primitives from POSIX or VxWorks

without manual setup ..............................

Start Page: Get quickly familiar with Polyspace Code
Prover . ....... . ...

Enhanced Review Scope: Filter coding rule violations from
display inoneclick ........... ... ... .. ... .. ... ....

Additional Call Graph Showing Task Creation ...........

Improved precision for mathematical functions ..........

2-2

2-2
2-2

2-5

2-5

2-6

2-6

2-6

2-7

2-7

2-8

2-8

2-9



Improved handling of declspec ..................... 2-9

Improvements in Polyspace Metrics workflow ........... 2-9
Updated Support for TargetLink ...................... 2-10
Improvements in Polyspace Plugin for Eclipse .......... 2-10

Improvements in automatic project creation from build
command ........ .. 2-11

Improvements in checking of previously supported MISRA C

rules .. ... e 2-12
MISRA C:2004 Rules . ........ .. ... .. 2-12
MISRA C:2012 Rules . ........ ... .. 2-13
Checking Coding Rules Using Text Files ............... 2-14

Including options multiple times . ..................... 2-14
Renaming of labels in Polyspace user interface ......... 2-15

Configuration Associated with Result Not Opened by

Default ... ... ... . 2-16
Improvements in Report Templates . .................. 2-16
Changes in analysisoptions .......................... 2-16
Change in Correctness Condition Check ............... 2-21
Binaries removed .. ........ ... ... . . .. i ... 2-22
Support for Visual Studio 2008 to be removed .. ......... 2-22
Import Visual Studio project removed ................. 2-23
XML and RTF report formats removed . ................ 2-23

vi Contents



R2015a

Simplified workflow for project setup and results review
with a unified user interface ........................

Review of code complexity metrics and global variable usage
in user interface . ......... ... ... .. ... ... . ... ...

Code Complexity Metrics .. ............vuiieenn...
Global Variables . .......... ... ... ...

Context-sensitive help for code complexity metrics, MISRA-
C:2012, and custom coding rules .....................

Detection of stack pointer dereference outside scope . . . ..
Review of latest results compared to the last run .........

Guidance for reviewing Polyspace Code Prover checks in C
code . ...

Improvements in search capability in the user interface . ..

Isolated ellipsis for variable number of function arguments
supported . ...... .. ...

Improvement in pointer comparisons ...................
Improvements in coding rules checking .................
Simplified results infrastructure ......................
Support for GCC 4.8 .. ... ... ... ... ... . . . .

Polyspace plug-in for Simulink improvements ..........
Integration with Simulink projects ...................
DRS file format changed to XML ....................
Back-to-model available when Simulink is closed ........

Polyspace binaries being removed .. ..................

Import Visual Studio project being removed ............

3-2

3-3
3-4

3-6

3-7

3-8

3-8

3-11
3-11
3-11
3-11
3-12
3-12
3-12

3-13

vii



viii

Contents

R2014b

Support for MISRA C:2012 .. ........ ... .. .. ... ... ......

Improved verification speed . .........................

Support for Mac OS . ........ ... ... .. ...

Improved verification precision for non-initialized
variables .. ... ... ...

Read Operations on Structures .......................

Other Operations ............c.uiii ..

Support for C++11 ... ... ... ... . e

Context-sensitive help for verification options and checks .

Code Editor for editing source files in Polyspace user
interface . ......... ... . ... ...

Local file-by-file verification ..........................

Simulink plug-in support for custom project files .........

TargetLink support updated ..........................

AUTOSAR support added . ............ ... ... .........

New checks for functions not called . ... ................

Default verification level changed .....................
Improved precision level .. ..........................

Default mode changed for C++ code verification in user
interface . ........ ... . ... .. ...

Updated Software Quality Objectives ... ...............

Improved global menu in user interface ...............

4-2

4-3

4-3

4-3

4-5

4-6

4-6

4-7

4-7

4-8

4-8

4-9

4-10

4-11

4-11

4-11



Improved Project Manager perspective ................ 4-12

Changed analysisoptions ............................ 4-13
Improved Results Manager perspective ................ 4-13
Error mode removed from coding rules checking ........ 4-15
Remote launcher and queue manager renamed ......... 4-15
Polyspace binaries being removed .. .................. 4-16
Import Visual Studio project being removed ............ 4-17

R2014a
Automatic project setup from build systems ............. 5-2

Support for GNU 4.7 and Microsoft Visual Studio C++ 2012
dialects . ....... ... ... . ... 5-2

Documentation in Japanese ........................... 5-3

Support for additional Coding Rules (MISRA C:2004 Rule

18.2, MISRA C++ Rule 5-0-11) ........................ 5-3
Preferences filemoved . ........ ... ... ... ........... 5-3
Support for batch analysis security levels . .............. 5-3
Interactive mode for remote verification ................ 5-4
Default text editor . ......... ... ... .. ... . ... ... 5-4
Results folder appearance in Project Browser . .......... 5-4
Results Manager improvements ....................... 5-6

ix



X

Contents

Simplification of coding rules checking ................. 5-8

Support for Windows 8 and Windows Server 2012 ... .. ... 5-9
Check model configuration automatically before analysis . 5-10
Additional back-to-model support for Simulink plug-in ... 5-10
Function replacement in Simulink plug-in ............. 5-10
Polyspace binaries being removed . ................... 5-11
Improvement of floating point precision ............... 5-11

R2013b

Proven absence of certain run-time errors in C and C++
code . ... 6-2

Color-coding of run-time errors directly in code .......... 6-2

Calculation of range information for variables, function
parameters and return values ... .................... 6-2

Identification of variables exceeding specified range limits 6-3

Quality metrics for tracking conformance to software quality
objectives . .. ... ... 6-3

Web-based dashboard providing code metrics and quality
Status .. ... e 6-4

Guided review-checking process for classifying results and

run-time error status ........... ... ... ... . .. ... 6-4
Graphical display of variable reads and writes ........... 6-5
Comparison with R2013a Polyspace products ............ 6-5



R2016a

Version: 9.5
New Features
Bug Fixes

Compatibility Considerations



R2016a

1-2

Files to Review: Generate results for only specified files and folders

In R20164a, you have greater control over the files on which you want analysis results.
The default project configuration displays coding rule violations and code metrics on the
set of files that are likely to be most relevant to you. You can add files or folders to this
set based on your requirements.

For instance, by default, coding rule violations and code metrics are generated on header
files that are located in the same folder as the source files. Often, other header files
belong to a third-party library. Though these header files are required for a precise
analysis, you are not interested in reviewing findings in those headers. Therefore, by
default, results are not generated for those headers. If you are interested in certain
headers from third-party libraries, you can add those headers to the subset on which
results are generated.

For more information, see:

* Generate results for sources and (-generate-results-for)
* Do not generate results for (-do-not-generate-results-for)

Compaitibility Considerations

In R2016a, by default, coding rule violations and code metrics are not generated for
headers unless they are in the same location as source files. Previously, if you ran
verification at the command line, by default, results were generated for all headers.

Due to the change in default behavior, if you rerun verification on a pre-R2016a project
without changing the options, you can lose review comments on findings in some header
files. To avoid losing the comments, set the option Generate results for sources and (-
generate-results-for) to all-headers.

Autocompletion for Review Comments: Partially type previous comment
to select complete comment

In R20164a, on the Results Summary or Result Details pane, if you start typing a
review comment that you have previously entered, a drop-down list shows the previous
entry. Select the previous comment from this list instead of retyping the comment.

If you want the autocompletion to be case sensitive, select Tools > Preferences. On the
Miscellaneous tab, select Autocomplete on Results Summary or Details is case
sensitive.



Faster MISRA Rule Checking: Check coding rules more quickly and
efficiently

In R20164a, you can use two predefined subsets to perform a quicker and more efficient
check for coding rule violations. The new subsets turn on rules that have the same scope.

+ single-unit-rules — Check rules that apply only to single translation units.

+ system-decidable-rules — Check rules in the single-unit-rules subset
and some rules that apply to the collective set of program files. The additional rules
can be checked only at the integration level because the rules involve more than one
translation unit.

Polyspace” finds these subsets of rules in the early phases of the analysis. If your project
is large, before checking all rules, you can check these subsets of rules for a preliminary
analysis.

For more information, see “Coding Rule Subsets Checked Early in Analysis”.

S-Function Analysis: Launch analysis of S-Function code from Simulink

With the Polyspace plug-in for Simulink®, you can now start a Polyspace verification on
S-Functions directly from an S-Function block.

To analyze an S-Function, right-click the S-Function block and select Polyspace >
Verify S-Function. If the S-Function occurs in your model multiple times, you can
choose to analyze all instances of the S-Function by verifying all signal range inputs, or
just a single instance of the S-Function by verifying the specific signal ranges for that

block.

Persistent Filter States: Apply filters once and view filtered results across
multiple runs

In R20164, if you apply a set of filters to your verification results and rerun verification
on the project module, your filters are also applied to the new results. You can specify

your filters once and suppress results that are not relevant for you across multiple runs.

The Results Summary pane shows the number of results filtered from the display. If
you place your cursor on this number, you can see the applied filters.
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Showing 187/365

Showing 187 out of 365 possible results
Hidden results: 178

Review Scope: Checks & Rules

Mew results only: On

Columns with active filters:

Information
Check

For instance, in the image, you can see that the following filters have been applied:

* The Checks & Rules filter to suppress code metrics and global variables.

. — :
The filter to suppress results found in a previous verification.

+ Filters on the Information and Check columns.

For more information, see “Filter and Group Results”.

Floating-Point Support: Propagate ranges more precisely for 1ong
double variables and enable verification mode to incorporate infinities
and NaNs

In R20164a, there are the following improvements on analysis of code involving floating-
point variables.

Long Doubles

If your code contains computations involving long double variables, you can see fewer
orange checks resulting from overapproximation. Previously, Polyspace assumed full-
range value for long double variables, irrespective of the actual values assigned to
them. This assumption led to orange checks that indicated potential numerical and other
errors in computations involving long double variables.

Polyspace now propagates ranges more precisely for long double variables. For
information on the number of bits that Polyspace uses for computations involving long
double variables, see Target processor type (-target).



Nonfinites in floating-point arithmetic

Polyspace verification supports nonfinite results such as infinities and NaNs from
computations involving floating-point variables. Using the option Allow non finite floats
(-allow-non-Ffinite-floats), you can enable a verification mode that incorporates

infinities and NaNs.

In this mode, Polyspace assumes that:

* Floating-point operations can produce results such as infinities and NaNs.

Using options —check-inFfinite and —check-nan, you can choose to highlight
operations that produce nonfinite results and stop the execution paths where the

nonfinite results occur.

* Floating-point variables with unknown values, such as volati le variables and
return values of stubbed functions, can be infinite or NaN.

The following table illustrates the change.

Prior to R2016a

R2016a

In the following code, Polyspace produces
a Division by zero error and stops
verification.

double func(void) {
double x=1.0/0.0;
double y=1.0/x;
double z=x-x;
return z;

In the following code, if you specify the
option Allow non finite floats, Polyspace
does not check for a Division by zero
error.

double func(void) {
double x=1.0/0.0;
double y=1.0/x;
double z=x-x;
return z;

}
The verification assumes that dividing by
zero results in:

+ Value of X equal to Inf

+ Value of y equal to 0.0

+ Value of z equal to NaN

In your verification results in the Polyspace
user interface, if you place your cursor on y

1-5
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Prior to R2016a

R2016a

and z, you can see the nonfinite values Inf
and NaN respectively in the tooltip.

Rounding modes

Polyspace supports verification that considers all possible rounding modes and extended
precision when rounding the results of floating point arithmetic. Using the option Float
rounding mode (-float-rounding-mode), you can enable a verification mode with the

following assumptions:

* These rounding modes are possible: round-to-nearest, round-towards-zero, round-
towards-positive-infinity and round-towards-negative-infinity.

The default assumption is round-to-nearest only.

+ Extended precision can be used for rounding.

The default assumption emulates the GCC flag -ffloat-store and disallows

extended precision.

Previously, the default verification assumed all rounding modes and extended precision
to determine the results of floating-point arithmetic. The verification used the round-to-
nearest mode without extended precision only to determine if an Overflow occurs.

The following table illustrates the change.

Prior to R2016a

R2016a

In the following code, Polyspace produces
a green Overflow check because the
addition does not overflow if the result is
rounded in to-nearest mode.

#include <float.h>

void func(void) {

double base = DBL_MAX;

double acc = 1.247400193459199882
285232945648024103792
1570377722e+291;

base = acc + base;

In the following code, if you specify all

for the option Float rounding mode,
Polyspace produces an orange Overflow
check because the addition overflows if the
result is rounded towards positive infinity.

#include <float.h>

void func(void) {

double base = DBL_MAX;

double acc = 1.247400193459199882
285232945648024103792
1570377722e+291;




Prior to R2016a R2016a

} base = acc + base;

}

Polyspace Metrics Tomcat Upgrade: Use upgraded default Tomcat server
or custom Tomcat version

Polyspace Metrics now uses Tomcat 8.0.22 to run the Polyspace Metrics web interface.

If you want to use your own version of Tomcat, you can now specify a custom Tomecat
server in the daemon configuration file. To add your custom tomcat web server, add the
following line to the daemon configuration file.

tomcat_install_dir = <path/to/tomcat>

The daemon configuration file is located in:

+ Windows — \%APPDATA%\Polyspace_RLDatas\polyspace.conf
* Linux — /etc/Polyspace/polyspace.conf

Updated Polyspace Metrics Interface: View summary of project and
metrics

You can now view project-level metric summaries from the main Polyspace Metrics page
using one of the following methods:

*  On the Projects tab, roll your mouse over the list of projects to open a window
displaying a summary of the project and project metrics.

*  On the Projects or Runs tab, right-click the column headers to add new columns to
the table. new columns you can add include Coding Rules, Bug-Finder Checks, Code
Metrics, and Review Progress.

Project Language Flexibility: Change your project language at any time

Projects in the Polyspace interface are no longer fixed to C or to C++. When you create
a project, you can add any file to the project. After you add files, select the language for
your analysis using the Source code language (- lang) option. If you add or change the
files in your project, you can change the language to reflect the most suitable analysis

type.
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Many options that were C only or C++ only are now available for both languages. To see
which analysis options have changed, see “Changes in analysis options” on page 1-14.

External Constraint on Pointers: Specify certain initialization with full
range for pointer arguments and return values of stubbed functions

In R20164, if a stubbed function in your code has a pointer argument or a return

value, you can specify certain constraints on the pointer outside your code. Using the
constraints, you can reduce the number of Non-initialized local variable checks. A
function is stubbed if you do not provide the function definition or if you specify the
function name for the option Functions to stub (-functions-to-stub). For instance, if
you declare a function func and do not provide the function definition, func is stubbed.

int* func (int* ptr);
You can specify the new external constraints for the pointer argument and the pointer
return value of func.

You can specify one of the following:
* The pointer points to a non-array variable and the variable is initialized.

The Init Allocated column in the constraint specification file supports a new entry
SINGLE_CERTAIN_WRITE that allows you to specify this constraint.

+ The pointer points to an array and all elements of the array are initialized.

The Init Allocated column in the constraint specification file supports a new entry
MULTI_CERTAIN_WRITE that allows you to specify this constraint.

The following table illustrates the change.

Prior to R2016a R2016a
Without constraints, Polyspace assumes If you specify the following constraints
that X in bar and and bar_array are in the Init Allocated column, Polyspace

potentially noninitialized when you read considers that X in bar and bar_array are
them. You cannot specify that the functions |initialized.
foo and foo_array initialize x with full-

range values. + fToo: Specify SINGLE_CERTAIN_WRITE
for the argument of foo. In other words,
#define SIZE 5 foo writes a value to *ptr.

id F int *ptr); 1
void foo(int *ptr) - foo_array: Specify

MULTI_CERTAIN_WRITE for the




Prior to R2016a R2016a

int bar (void) { argument of foo_array. In other
int Xx; words, ptr points to an array and
foo(&x); foo_array writes a value to the array
3 LTSS elements.

; ; #define SIZE 5
void foo_array(int *ptr); void foo(int *ptr);
void display(int val);

int bar (void) {

void bar_array(void) { int x:
int x[SI1ZE],sum=0; foo(&x);
foo_array(x); return x:
for(int i=0; I<SIZE; i++) }
display(x[il);
3 void foo_array(int *ptr);

void display(int val);

void bar_array(void) {
int xX[SI1ZE],sum=0;
foo_array(x);
for(int i=0; I<SIZE; i++)
display(x[i]);

For more information, see “Constraints”.

If your project uses a constraint specification file from a previous release, you do not see
any change in the verification results. If you generate a constraint specification file, by
default, pointer arguments of stubbed functions are constrained to point to an array that
1s initialized. Applying the default constraint specification file can reduce the number of
orange Non-initialized local variable checks.

Improved Result Display for File-by-File Verification: View combined
summary of results for all files in user interface

In R20164a, if you perform a file-by-file verification, you can see a summary of results for
all files on the Dashboard pane. You can open the results for each file directly from this

summary table. Previously, you obtained this synthesis in an external html file.

For more information, see “Run File-by-File Local Verification”.
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Source Code Search: Search large applications more quickly

In R2016a, search results are produced more quickly. If you search for a string in a large
application, it takes less time for search results to appear.

You can search for a string either by entering the search string in the box on the Search
pane, or by right-clicking a word in your code on the Source pane, and then selecting a
search option.

Default Layouts: Switch easily between project setup and results review in
user interface

In R20164a, you have two default layouts of panes in the Polyspace user interface, one for
project setup and another for results review.

When setting up your projects, select Window > Reset Layout > Project Setup. When
reviewing results, select Window > Reset Layout > Results Review.

For more information, see “Organize Layout of Polyspace User Interface”.

Simplified Variable Access: View task names instead of aliases

In R20164a, on the Variable Access pane, in the Written by task and Read by task
columns, you see the task names. Previously, the columns contained aliases such as t1,
t2, t3, ... You viewed the task names using a legend for the aliases.

Polyspace Targetlink plug-in supports data from structures

The Polyspace plug-in for TargetLink® can now import data from structures in the
constraint specifications (formerly called DRS) for your analysis.

Polyspace Eclipse plug-in results location moved

When you analyze projects using the Polyspace plug-in for Eclipse™, your results used
to be stored inside your Eclipse project under eclipse project folder\polyspace.
For new Eclipse projects, Polyspace now stores results in the Polyspace Workspace
under Polyspace Workspace\EclipseProjects\Eclipse Project Name, where
Polyspace_Workspace is the default project location specified in your Polyspace
Interface preferences. For more information, see “Results Location”.



Improvements in automatic project creation from build command

In R2016a, automatic project creation from build command is improved.

If you trace your build command and create a Polyspace project from the command
line, you do not have to specify a product name or project language. You can open the
project in Polyspace Bug Finder™ or Polyspace Code Prover™. The project language
is determined by using the following rules:

If all your files are compiled as C, as C++03, or C++11, the corresponding language
1s assigned to the project.

Language Options Set in Project

C Source code language: c

C++03 Source code language: cpp

C++11 Source code language: cpp
C++11 Extensions: On

+ If some files are compiled as C and the remaining files as C++03 or C++11, the
Source code language option is set to cpp.

The option C++11 Extensions is also enabled.

For more information, see Source code language (- lang) and C++11 Extensions (-
cppll-extensions).

Previously, you specified the product name by using options ~bug-finder or -code-
prover. If you did not specify a project language and your source code consisted of
both .c and .cpp files, the language cpp was assigned to the project. The options -
bug-finder and —code-prover have been removed.

For more information, see “Create Project Automatically”.

If header files in your project contain constructs that are not supported in Polyspace
Code Prover, a compilation error occurs. In R2016a, when you trace your build,
Polyspace detects such header files and does not add them to your project. Later,
when you run verification on the project, you do not face compilation errors because of
unsupported constructs in header files.

The support for IAR compilers has improved. All variations of IAR compilers are now
supported for automatic project creation from build command.

1-11



R2016a

1-12

Improvements in checking of previously supported MISRA C rules

In R20164a, the following changes have been made in checking of previously supported

MISRA C® rules.
MISRA C:2004 Rules

Rule

Description

Improvement

MISRA C:2004 Rule
10.3

The value of a complex
expression of integer
type may only be

cast to a type that is
narrower and of the
same signedness as
the underlying type of
the expression.

The rule checker no longer raises a
violation of this rule if an expression
with a Boolean result is cast to a type
that is also effectively Boolean.

For instance, in your code, you define
a type myBool using a typedef

and cast the result of (a && b) to
myBool. If you specify to Polyspace
that myBool is effectively Boolean,
the rule checker does not consider
this cast as a violation of rule 10.3.
For more information on how to
specify effectively Boolean types, see
Effective boolean types (-boolean-

types).

MISRA C:2004 Rule
12.2

The value of an
expression shall be the
same under any order
of evaluation that the
standard permits.

The rule checker no longer flags
expressions with the comma operator
that can be evaluated in only one
order.

For instance, the statement ans =
(val++, val++) does not violate
this rule.

MISRA C:2012 Rules

Rule

Description

Improvement

MISRA C:2012 Rule
13.2

The value of an
expression and its
persistent side effects

The rule checker no longer flags
expressions with the comma operator




Rule Description Improvement

shall be the same that can be evaluated in only one
under all permitted order.

evaluation orders.
For instance, the statement ans =

(val++, val++) does not violate
this rule.

Absolute address usage valid by default

In R20164a, the Absolute address usage check is considered valid and therefore green
by default. If you assign an absolute address to a pointer in your code, the verification
assumes that:

* The address is valid.

* The type of the pointer to which you assign the address determines the initial value
stored in the address.

If you assign the address to an Int* pointer, the memory zone that the address points
to is initialized with an Int value. The value can be anything that is allowed for the
data type int.

Previously, the Absolute address usage check was considered possibly invalid and
therefore orange by default. You either justified the checks or turned them green by
using the option Green absolute address checks (-green-absolute-address-
checks on command line).

Compatibility Considerations

If the code in your project uses absolute addresses, you see a decrease in the number of
orange checks from previous releases of the software. To turn the check orange by default
for each absolute address usage, use the command-line option —no-assumption-on-
absolute-addresses. To use a command-line option in the user interface, enter the
option in the Other field.

Variables with constraints not counted as orange sources

In R20164a, once you constrain certain variables outside your code, those variables do not
appear as possible causes of orange checks on the Orange Sources pane.

1-13




R2016a

This pane lists the variables that you can constrain outside your code to reduce orange
checks.

* Previously, the pane listed variables even after you had constrained them, with the
assumption that you might constrain them further.

+ Starting in R2016a, Polyspace assumes that once you constrain variables to match
real-world values, you will not constrain them further.

Therefore, variables already constrained are not shown on the Orange Sources pane.

For more information on constraining variables using the Orange Sources pane, see
“Create Constraint Template After Verification”.

Changes in analysis options
In R2016a, the following options have been added, changed, or removed.

New Options

Option Description

Generate results for sources and |Specify files on which you want analysis results.
(-generate-results-for)

Do not generate results for (-do- |Specify files on which you do not want analysis
not-generate-results-for) |results.

Allow non finite floats (-allow- |[Enable a verification mode that incorporates

non-finite-floats) infinities and NaNs.

Float rounding mode (-Float- |Assume all rounding modes and extended precision

rounding-mode) when determining the results of floating point
arithmetic.

-check-infinite Specify how to handle floating point operations that
result in infinity.

-check-nan Specify how to handle floating point operations that
result in NaN.

-no-assumption-on- Make Absolute address usage checks orange by

absolute-addresses default.

Updated Options
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Option

Change

More
Information

Source code language (- lang)

Added to Polyspace Interface

Select your
project
language to set
compilation
rules and
enable
language
specific
analysis
options.

Dialect (-dialect)

Unified dialects for C and C++
projects. All projects can use any
dialect option.

Target processor type (-target)

Targets 1386 and x86_64 now allow

any alignment value.

Sfr type support (-sfr-types)

Allowed for both C and C++

Pack alignment value (-pack-
alignment-value)

Allowed for both C and C++

Import folder (- import-dir)

Allowed for both C and C++

Ignore pragma pack directives (-
ignore-pragma-pack)

Allowed for both C and C++

Division round down (-div-
round-down)

Allowed for both C and C++

Removed Options

Option Status More Information
Green absolute address Warning |Absolute address usage checks are green
checks (-green-absolute- by default. To remove this assumption
address-checks) and produce an orange check, use
the option -no-assumption-on-
absolute-addresses.
Files and folders to ignore (- |Warning |Use the option Do not generate results
includes-to-ignore) for (-do-not-generate-results-
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Option Status More Information
for) to suppress results from headers
and sources in certain files or folders.

Ignore float rounding (- Warning |Option will be removed in a future

ignore-float-rounding) release.

-retype-pointer Warning |Option will be removed in a future
release.

-retype-int-pointer Warning |Option will be removed in a future
release.

—-lwtm Warning |Option will be removed in a future
release.

-support-FX-option-results|Warning |Option will be removed in a future
release.

polyspace-vcproj Error Binary has been removed.

Compatibility Considerations

If you use scripts that contain the removed or updated options, change your scripts
accordingly.

Run-time checks renamed

In R2016a, the following checks have been renamed. The new names state the error in
the code instead of what the check looks for.

Old Name New Name

Absolute address Absolute address usage

C++ specific checks Invalid C++ specific operations
Exception handling Uncaught exception

Function Returns a Value Function not returning value
Initialized Return Value Return value not initialized
Non-null this-pointer in Null this-pointer calling method
method
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Object Oriented Incorrect object oriented programming
Programming
Shift operations Invalid shift operations
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Option to Suppress Non-initialization Checks: Customize verification by
suppressing non-initialization checks

In R2015b, you can use an analysis option to turn off the checks for non-initialization. If
you turn on this option, Polyspace assumes that, at declaration:
* Variables have full-range of values allowed by their type.

+ Pointers can be NULL-valued or point to a memory block at an unknown offset.
When you use this option, the following checks are turned off:

* Non-initialized local variable: Local variable is not initialized before being read.

+ Non-initialized variable: Variable other than local variable is not initialized before
being read.

* Non-initialized pointer: Pointer is not initialized before being read.

* Return value not initialized: C function does not return value when expected.

For more information, see Disable checks for non-initialization (C/C++).

Improved Concurrency Detection: View more precise sharing and
protection results based on dynamic information such as data flow in

branching statements and protection on individual fields of a structure

In R2015b, Polyspace Code Prover uses dynamic information such as data flow in branch
statements to determine whether a variable is shared and protected. Previously, sharing
and protection were determined statically resulting in overapproximation of the actual

behavior. For more information on shared variables and multitasking options, see
Multitasking.

The following examples illustrate the change. For more examples, see Global Variables.

Data Flow in Branch Statements

Prior to R2015b R2015b

In the following code, if you specify taskl
and task?2 as entry points, the verification
determines that var_1 and var_2 are
shared, potentially unprotected variables.
However, because of the i f statement,

taskl can operate only on var_1 and

In the following code, if you specify taskl

and task?2 as entry points, the verification
determines that var_1 and var_2 are not

shared.

unsigned int var_1;



http://www.mathworks.com/help/releases/R2015b/codeprover/ref/noninitializedlocalvariable.html
http://www.mathworks.com/help/releases/R2015b/codeprover/ref/noninitializedvariable.html
http://www.mathworks.com/help/releases/R2015b/codeprover/ref/noninitializedpointer.html
http://www.mathworks.com/help/releases/R2015b/codeprover/ref/returnvaluenotinitialized.html
http://www.mathworks.com/help/releases/R2015b/codeprover/ref/disable-checks-for-non-initialization.html
http://www.mathworks.com/help/releases/R2015b/codeprover/multitasking.html
http://www.mathworks.com/help/releases/R2015b/codeprover/global-variable-reference.html

Prior to R2015b

R2015b

task2 only on var_2. When determining
sharing, the verification does not consider
the branching in the i f statement and
therefore determines that var_1 and
var_2 are shared.

unsigned int var_1;
unsigned int var_2;
volatile int randomval;

void taskl(void) {

unsigned int var_2;
volatile int randomVal;

void taskl(void) {
while(randomVal)
operation(l);
}

void task2(void) {
while(randomVal)
operation(2);

while(randomval) h
} operation(l); void operation(int 1) {
if(i==1) {
void task2(void) { VL=
while(randomval) }I
operation(2); © sevar §++.
¥ } - 7
void operation(int 1) { 3
If(l\:,;)lir- int main(void) {
} - ’ return O;
else { 3
var_2++;
}
¥
int main(void) {
return O;
¥
Shared Structures
Prior to R2015b R2015b

In the following code, if you specify taskl
and task?2 as entry points, the verification
determines that the structure variable
sharedStruct is a potentially unprotected
variable. However, taskl can operate only

In the following code, if you specify taskl
and task?2 as entry points, the verification
determines that the structure variable
sharedStruct is a shared, protected
variable. If you select the result, the




R2015b

Prior to R2015b

R2015b

on sharedStruct.var_1 and task?2 only
on sharedStruct.var_2. The verification
considers sharedStruct as a whole and
ignores the sharing and protection on
individual fields of sharedStruct.

struct S {
unsigned int var_1;
unsigned int var_2;

};
volatile int randomval;
struct S sharedStruct;

void taskl(void) {
while(randomval)
operationl();

}

void task2(void) {
while(randomval)
operation2();

}

void operationl(void) {
sharedStruct.var_1++;

}

void operation2(void) {
sharedStruct.var_2++;

}

int main(void) {
return O;

}

Result Details pane states that all
operations on the variable are protected
by access pattern. For the variable
sharedStruct, the Protection column
on the Variable Access pane contains
Access pattern.

struct S {
unsigned int var_1;
unsigned int var_2;

};
volatile int randomVal;
struct S sharedStruct;

void taskl(void) {
while(randomVal)
operationl();

}

void task2(void) {
while(randomVal)
operation2();

}

void operationl(void) {
sharedStruct._var_1++;

}

void operation2(void) {
sharedStruct.var_2++;

}

int main(void) {
return O;

}




Microsoft Visual C++ 2013 Support: Analyze code developed in Microsoft
Visual C++ 2013

You can analyze code developed in the Microsoft® Visual C++* 2013 dialect.

To analyze code compiled with Microsoft Visual C++ 2013, set your dialect to
visuall12.0. If you specify the dialect, Polyspace allows language extensions specific to
Microsoft Visual C++ 2013. Otherwise, it produces a compilation error if you use those
extensions. For more information, see Dialect (C/C++) or Dialect (C++).

Additional MISRA C:2012 Support: Detect violations of all MISRA C:2012
rules except rules 22.x
In R2015b, Polyspace Code Prover supports the following MISRA C: 2012 coding rules.

For complete MISRA C: 2012 support, including rules 22.1-22.4 and 22.6, use Polyspace
Bug Finder.

Rule Description
MISRA C:2012 Directive 2.1 | All source files shall compile without any compilation
errors.

MISRA C:2012 Directive 4.5 |Identifiers in the same name space with overlapping
visibility should be typographically unambiguous.

MISRA C:2012 Rule 2.6 A function should not contain unused label declarations.
MISRA C:2012 Rule 2.7 There should be no unused parameters in functions.

MISRA C:2012 Rule 17.5 The function argument corresponding to a parameter
declared to have an array type shall have an appropriate
number of elements.

MISRA C:2012 Rule 17.8 A function parameter should not be modified.

MISRA C:2012 Rule 21.12 | The exception handling features of <fenv.h> should not
be used.

MISRA C:2012 Rule 22.5 A pointer to a FILE object shall not be dereferenced.
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GNU 4.9 and Clang 3.5 Support: Analyze code compiled with GCC 4.9
or Clang 3.5

Polyspace now supports the GNU 4.9 and Clang 3.5 dialects for C and C++ projects.

To analyze code compiled with one of these dialects, set the Target & Compiler >
Dialect option to gnu4 .9 or clang3.5.

For more information, see Dialect (C/C++) or Dialect (C++).

Improved Review Capability: View result details and add review
comments in one window

In R2015b, the Check Details pane is renamed Result Details. On this pane, in
addition to viewing details about a result, you can now enter review information such
as Classification, Status, and comments. For more information, see Add Review
Comments to Results.

Y e eeeeeeeeeeee——————————————————————————
2 0@ |1=E. £ | _ﬁt X single_file_analysis.c / reset_temperature()

=l Result Review

Classification -High - | o perform checks for array index.

Status Fix =

! Out of bounds array index

Error: array index is outside its bounds : [0..38]
array size: 39
array index value: [-255 ., -39]

Saved Layouts: Save your preferred layouts of the Polyspace user
interface

In R2015b, if you reorganize the Polyspace user interface and place the various panes in
more convenient locations, you can save your new layout. If you change your layout, you
can quickly revert to a saved layout.
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With this modification, you can create customized layouts suitable for different
requirements and switch between saved layouts. For instance:

* You can have separate layouts for project configuration and results review.

* You can have a minimal layout with only frequently used panes.

For more information, see Organize Layout of Polyspace User Interface.

Autodetection of Multitasking Primitives: Analyze source code with
multitasking primitives from POSIX or VxWorks without manual setup

If you use POSIX® or VxWorks® to perform multitasking, Polyspace can now interpret
your multitasking code without having to change your code or manually set multiple
configuration options.

To turn on automatic detection, select the analysis option Multitasking > Enable
automatic concurrency detection. Polyspace detects thread creation and critical
sections from supported multitasking functions.

Functions Polyspace can interpret:
POSIX

* pthread_create
* pthread_mutex_lock
+ pthread_mutex_unlock

VxWorks

+ taskSpawn
+ semTake

+ semGive

For more information, see Enable automatic concurrency detection (C/C++).

Start Page: Get quickly familiar with Polyspace Code Prover

In R2015b, when you open Polyspace Code Prover for the first time, a Start Page pane
appears. From this pane, you can:
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*  Open recent results and demo examples.
* Start a new project.
* Get additional help using the Getting Started, What’s New and Learn More tabs.

If you select the Show on startup box on the lower left of this pane, the pane appears
each time you open Polyspace Code Prover. Otherwise, if you close the pane once, it does
not reopen. To open the pane, select Window > Show/Hide View > Start Page.

Enhanced Review Scope: Filter coding rule violations from display in one

click

In R2015b, you can suppress a certain number or percentage of coding rule violations
from the display using custom options in the Show menu on the Results Summary
pane. You can:

*  Suppress violations of coding rules that are not relevant for you.

*  Focus your results review by seeing only a certain number of coding rule violations in
your display.

* Predefine a percentage of coding rule violations that you intend to review. View only
that percentage in your analysis results.

You define an option on the Show menu only once. The option is available for one-click
use every time that you open your results. For more information, see Suppress Certain
Rules from Display in One Click.

Previously, using custom options on the Show menu, you suppressed orange checks
and code metrics (if they fell below a certain threshold). With this enhancement, you
can use the Show menu to display only those results that must be justified to reach a
certain Software Quality Objective (SQO) level. For instance, you can reach predefined
SQO levels 4, 5, and 6 using the options on the Show menu. For more information, see
Software Quality Objectives.

Additional Call Graph Showing Task Creation

For global variables, the call graph provides a visual representation of the function call
sequence leading to operations on the variable. In R2015b, the call graph for shared
global variables has been augmented with a supporting call graph that shows task
creation.


http://www.mathworks.com/help/releases/R2015b/codeprover/ug/apply-coding-rule-violation-filters.html#buxio8b
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Previously, Polyspace modeled multitasking code by assuming that all tasks begin after
the main completes execution. This model has been relaxed for POSIX thread creation
functions allowing creation of tasks in the main and in functions called from the main.
Therefore, the call sequence leading to the creation of a task can be nontrivial. The task
creation call graph provides you a visual representation of this call sequence.

For more information, see Review Global Variable Usage.

Improved precision for mathematical functions

Polyspace Code Prover has more precise implementations for mathematical functions
defined in math.h.

Improved handling of __declspec

For projects in Visual C, Polyspace Code Prover can now interpret the aligned size
specified by the keyword __declspec( align( .. ) .. ).

For example, this structure uses the _declspec keyword:

struct S1 { _ declspec(align(8)) char c; };
In R2015b Polyspace correctly interprets the size of S1 as 8 bytes.

Compatibility Considerations

In previous versions, Polyspace ignored the _declspec keyword, so code with the
__declspec(align() ) keyword was verifiable using Dialect > None. To avoid
compilation errors with the R2015b support of __declspec(align() ), set Dialect to
one of the Visual C dialects. For the list of supported Visual dialects, see Dialect (C/C++).
Improvements in Polyspace Metrics workflow

In R2015b, the Polyspace Metrics workflow has improved in the following ways:

* You can justify code complexity metrics in the Polyspace user interface and upload the
justifications to Polyspace Metrics. If a code metric value violates quality thresholds

and appears red, after justification, it appears green with the v icon.
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For more information about justifying Polyspace results starting from the Polyspace
Metrics interface, see Compare Metrics Against Software Quality Objectives.

You can define custom SQO levels specific to a project. In the file Custom-SQ0-
Definitions.xml, if you specify a project name, in the Polyspace Metrics web
dashboard, the custom SQO level appears only for that project. You can choose this
SQO level to compare the project against quality thresholds that you defined. For
more information, see Customize Software Quality Objectives.

In the Polyspace user interface, the same menu item Metrics > Upload to
Metrics allows you to upload your results initially and also upload comments and
justifications in the results later.

Previously, you used a different menu item Save comments to Metrics to save your
review comments and justifications in a result.

For more information on uploading comments and justifications from the Polyspace
user interface to the Polyspace Metrics web interface, see Review Metrics for
Particular Project or Run.

Updated Support for Targetlink

The Polyspace plug-in for TargetLink now supports versions 3.5 and 4.0 of the dSPACE®
Data Dictionary and TargetLink Code Generator.

dSPACE and TargetLink version 3.4 is no longer supported.

For more information, see TargetLink Considerations.

Improvements in Polyspace Plugin for Eclipse

In R2015b, the following improvements have been made to the Polyspace plugin for
Eclipse:

When you select a result in the Results Summary view, the Result Details view
displays additional information about the result. In the Result Details view, if

you click the ‘2 button next to the result name, you can see a brief description and
examples of the result.

You can switch to a Polyspace perspective that shows only the information relevant to
a Polyspace Code Prover verification. To open the perspective, select Window > Open
Perspective > Other. In the Open Perspective dialog box, select Polyspace.
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Improvements in automatic project creation from build command

In R2015b, automatic project creation from build command is improved.

If you build your source code from the Cygwin™ environment (using either a 32 or
64-bit installation), Polyspace can trace your build and create a Polyspace project or
options file.

Support for the following compilers has improved:

+ Texas Instruments™ C2000 compiler

This compiler is available with Code Composer Studio™.
* Cosmic HCO08 C compiler
+ MPLAB XC8 C Compiler

With certain compilers, the speed of tracing your build command has improved.
The software now stores build information in the system temporary folder, thereby
allowing faster access during the build.

If you still encounter a slow build, use the advanced option ~cache-path ./
ps_cache when tracing your build. For more information, see Slow Build Process
When Polyspace Traces the Build.

If the software detects target settings that correspond to a standard processor type, it
assigns that standard target processor type to your project. The target processor type
defines the size of fundamental data types and the endianness of the target machine.
For more information, see Target processor type (C/C++).

Previously, when you created a project from your build command, the

software assigned a custom target processor type. Although you saw

the processor type in the form of an option such as -~custom-target
true,8,2,4,-1,4,8,4,8,8,4,8,1,little,unsigned_int, int,unsigned_short,
you could not identify easily how many bits were associated with each fundamental

type. With this enhancement, when the software assigns a processor type, you can
identify the number of bits for each type. Click the Edit button for the option Target
processor type.

Automatic project creation uses a configuration file written for specific compilers. If
your compiler is not supported, you can adapt one of the existing configuration files
for your compiler. The configuration file, written in XML, is now simplified with some
new elements, macros and attributes.
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+ The preprocess_options_list element supports a new $(OUTPUT_FILE)
macro when the compiler does not allow sending the preprocessed file to the

standard output.

* A new preprocessed_output_Tfile element allows the preprocessed file name
to be adapted from the source file name.

+ The semantic_options element supports a new IsPrefix attribute. This
attribute provides a shortcut to specify multiple semantic options that begin with

the same prefix.

+ The semantic_options element supports a new numArgs attribute. This
attribute provides a shortcut to specify semantic options that take one or more

arguments.

For more information, see Compiler Not Supported for Project Creation from Build

Systems.

*  Sometimes, the build command returns a non-zero status even when the command
succeeds. The non-zero status can result from warnings in the build process. However,
Polyspace does not trace the build and create a Polyspace project. You can now use
an option —al low-build-error to create a Polyspace project even if the build
command returns an exit status or error level different from zero. This option helps

you understand the error in the build process.

For more information, see —option value arguments of polyspaceConfigure.

Improvements in checking of previously supported MISRA C rules

In R2015b, the following changes have been made in checking of previously supported

MISRA C rules.

MISRA C:2004 Rules

Rule Description Improvement

MISRA C:2004 Rule |Assembly language If an assembly language statement
2.1 shall be encapsulated |is entirely encapsulated in macros,

and isolated.

Polyspace no longer considers that the
statement violates this rule.

MISRA C:2004 Rule
8.8

An external object
or function shall be

Polyspace considers that variables or
functions declared extern in a non-
header file violate this rule.
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Rule

Description

Improvement

declared in one file
and only one file.

MISRA C:2004 Rule
10.1

The value of an
expression of integer
type shall not be
implicitly converted to
a different underlying
type if it is not a
conversion to a wider
integer type of the
same signedness.

Polyspace no longer raises violation
of this rule on operations involving
pointers.

MISRA C:2004 Rule
19.2

Nonstandard
characters should not
occur in header file
names in #include
directives.

Polyspace no longer raises violation
of this rule if the character \ or \

\ occurs between the < and > in
#include <filename> (or between
"and " in #include "filename").
Therefore, you can use Windows®
paths to files in place of Fi lename
without triggering a rule violation.

MISRA C:2012 Rules

Rule

Description

Improvement

MISRA C:2012 Directive
4.3

Assembly language
shall be encapsulated
and isolated.

If an assembly language statement

is entirely encapsulated in macros,
Polyspace no longer considers that the
statement violates this rule.

MISRA C:2012 Rule 1.1

The program shall
contain no violations of
the standard C syntax
and constraints, and
shall not exceed the
implementation's
translation limits.

If a rule violation occurs because your
-c file contains too many macros,
instead of placing the rule violation
on the last macro usage, Polyspace
places the rule violation at the
beginning of the file.

Therefore, you can add a comment
before the first line of the .c file
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Rule

Description

Improvement

justifying the violation. Previously,
you had to place the comment before
the last macro usage. If you added
another use of the macro later,

the comment did not apply. For
information on adding code comments
to justify results, see Add Review
Comments to Code.

MISRA C:2012 Rule
10.4

Both operands of an
operator in which
the usual arithmetic
conversions are
performed shall have
the same essential
type category.

If one of the operands is the
constant zero, Polyspace does not
raise a violation of this rule.

If one of the operands is a signed
constant and the other operand

1s unsigned, the rule violation is
not raised if the signed constant
has the same representation as its
unsigned equivalent.

For instance, the statement u8b =
u8a + 3;, where u8a and u8b are
unsigned char variables, does
not violate the rule because the
constants 3 and 3U have the same
representation.

Checking Coding Rules Using Text Files

In R2015b, if your coding rules configuration text file has an incorrect syntax, the
analysis stops with an error message. The error message states the line numbers in the

configuration file that contain the incorrect syntax.

For more information on checking for coding rules using text files, see Select Specific
MISRA or JSF Coding Rules.

Including options multiple times

You can now specify analysis options multiple times. This feature is available only at
the command line or using the command-line names in the Advanced options dialog
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box in the user interface. Customize pre-made configurations without having to find the
changed options in the options file.

If you specify an option multiple times, only the last setting is used. For example, if your
configuration is:

-lang c

-prog test_bf _cp
-verif-version 1.0

-author username
-sources-list-file sources.txt
-0S-target no-predefined-0S
-target 1386

-dialect none

-misra-cpp required-rules
-target powerpc

Polyspace uses the last target setting, powerpc, and ignores the other target specified,
1386.

The user interface also follows this rule. If you specify c18 for Target processor type
and -target 1386 for Advanced options, this counts as multiple analysis option
specifications. Polyspace uses the target specified in the Advanced options box, 1386.

Compatibility Considerations

If your current configuration specifies analysis options multiple times, change the
configuration by either:
*  Removing the unnecessary analysis options.

*  Moving the desired analysis options to the end of the configuration.

Renaming of labels in Polyspace user interface

In the Polyspace user interface, the following labels have been renamed:

*  On the Configuration pane, the node Coding Rules is changed to Coding Rules
& Code Metrics. The Coding Rules & Code Metrics node contains the option
Calculate Code Metrics, which appeared previously on the Advanced Settings
node.

*  On the Results Summary pane, the Category column title is changed to Group,
avoiding confusion with coding rule categories.
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*  On the Results Summary and Result Details pane, the field Classification is
changed to Severity. You assign a Severity such as High, Medium and Low to a
defect to indicate how critical you consider the issue.

* The labels associated with specifying constraints have changed as follows:

*  On the Configuration pane, the field Variable/function range setup is
changed to Constraint setup.

* When you click Edit beside the Constraint setup field, a new window opens. The
window name is changed from Polyspace DRS Configuration to Constraint
Specification.

For more information, see Specify Constraints.

Configuration Associated with Result Not Opened by Default

In R2015b, when you open your result, the Configuration pane does not automatically
display a read-only form of the associated configuration.

To view the configuration associated with the result, select the link View configuration
for results on the Dashboard pane. If a corresponding project is open on the Project
Browser pane, you can also right-click the result under the Results node in the project
and select Open Configuration.

Improvements in Report Templates

In R2015b, the major improvements in report templates include the following:

+ Instead of filenames, absolute paths to files appear in the reports.

+ If you check for coding rules, the appendix about coding rules configuration states all
rules along with the information whether they were enabled or disabled. Previously,
the appendix only stated the enabled rules.

For more information on templates, see Report template (C/C++).

Changes in analysis options
In R2015b, the following options have been added or removed.

New Options
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Option Status More information

Respect C90 Standard New The analysis does not allow C language
extensions that do not follow the ISO/IEC

(-no-language- 9899:1990 standard.

extensions)

Dialect visuall2.0 New Allows Microsoft Visual C++ 2013 (visual
12) language extensions.

Dialect gnu4.9 New Allows GCC 4.9 language extensions.

Dialect clang3.5 New Allows Clang 3.5 language extensions.

Configure multitasking New This option enables the previous

manually (C/C++) multitasking options (Entry points,
Critical section details, Temporally
exclusive tasks) in the user interface.

Enable automatic New Enables automatic concurrency detection

concurrency detection (C/C+
+)

for POSIX® and VxWorks® threading
functions.

Disable checks for non- New Disables checks for non-initialization in
initialization (C/C++) your code.

Updated Options

Option Status More information

Calculate Code Metrics (C/C
++)

Moved in user
interface

The option has been moved in the
Configuration panel from the Advanced
Settings pane to the Coding Rules and
Code Metrics pane.

-class-analyzer

Updated syntax

The syntax for —-class-analyzer
param has been updated. Use -class-
analyzer custom=param

Signed right shift (C/C++)

(-logical-signed-
right-shift)

Now available
in C++ projects

Division round down (C/C+
+)

Now available
in C++ projects
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Option

Status

More information

(-div-round-down)

(-no-def-init-glob)

Now available
in C++ projects

Optimize large static
initializers (C/C++)

(-no-fold)

Now available
in C++ projects

-lightweight-thread-
model

No longer
available in the
user interface

Targets: Now available
in C++ projects

* tms320c3x

, Sharc21x61

necv850
+ hc08
+ hcl2

MPC5XX
- cl8
Enum type definition (C/C+ |Possible values |The possible values for —~enum-type-
+) updated definition are the same for C and C++.

Available values:

(-enum-type-
definition) + defined-by-standard (default)

+ auto-signed-first
auto-unsigned-first

-asm-begin -asm-end

Now available
in C++ projects

-support-FX-option-
results

No longer
available in the
user interface

-pointer-is-24bits

Available in C+
+ projects

Availably only if you use the Target
setting c18.
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Option

Status

More information

Output format (C/C++)

Possible values

The output format RTF is deprecated

updated and not available on the Configuration

-report-output-format pane.

Removed Options

Option Status More information

-dialect cfront2 Removed |Use a different dialect instead.

-dialect cfront3 Removed | Use a different dialect instead.

-known-NTC Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-desktop Removed |Use -main-generator instead.

-permissive Removed | Use -allow-negative-operand-in-shift
—-ignore-constant-overflows instead.

-automatic-stubbing Removed |Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-float-overflows Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-continue-with- Removed |Polyspace includes this behavior by

exisiting-host default. Remove this option from existing
configurations.

-allow-unsupported- Removed | Polyspace includes this behavior by

linux default. Remove this option from existing
configurations.

-passes-time Removed |Polyspace includes this behavior by
default. Remove this option from existing
configurations.

—-ignore-missing- Removed | Polyspace includes this behavior by

headers

default. Remove this option from existing
configurations.
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Option Status More information

-continue-with-red- Removed | Polyspace includes this behavior by

error default. Remove this option from existing
configurations.

-voa Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-machine-architecture |Removed |Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-allow-non-int- Removed | Polyspace includes this behavior by

bitfield default. Remove this option from existing
configurations.

-allow-undef- Removed | Polyspace includes this behavior by

variables default. Remove this option from existing
configurations.

-allow-unnamed-fields |Removed  Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-permissive stubber Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-permissive-link Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-allow-language- Removed | Polyspace includes this behavior by

extensions default. Remove this option from existing
configurations.

-include-headers-once |Removed |Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-strict Removed | This option is no longer supported. Remove
this option from existing configurations.

-discard-asm Removed |This option is no longer supported. Remove

this option from existing configurations.




Option Status More information

-quick Removed Use -to passO instead.
-detect-unsigned- Removed |Use -scalar-overflows-checks-signed-
overflows and-unsigned instead.

-misra2 AC-AGC-OBL- Removed |Use -misra-ac-agc OBL-rules instead.
subset

Compatibility Considerations

If you use scripts that contain a removed or updated option, change your scripts
accordingly.

Change in Correctness Condition Check

In R2015b, the specification of the Correctness Condition check has changed in the
following way. For more information on the check, see Correctness condition.

When you use a function pointer to call a function and Polyspace cannot determine which
function the pointer points to, the Correctness Condition check is orange instead of
red. This situation can occur, for instance, if:

* The function pointer points to an absolute address. The check is orange because the
verification cannot determine from the code whether the absolute address contains a
well-typed function.

* The function pointer contains the return value of a stubbed function. For information
on stubbing, see Assumptions About Stubbed Functions.

Following the orange check, the verification assumes that the following variables can
have the full range of values allowed by their type:

* Variable storing the return value from the function call.

* Variables that can be modified through the function arguments.

Compatibility Considerations
If your code contains function pointers that point to an absolute address for instance,

you can see a change in the number of results from a previous version of the product.
Because red checks stop further verification of the code in the current block and orange
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checks do not, this change of the Correctness Condition check from red to orange can
expose more of your code to verification. Therefore, the number of checks in your code can

change.

Binaries removed

The following binaries have been removed.

Binary name

Use instead

polyspace-automatic -orange-
tester.exe

From the Polyspace environment, select Tools >

Automatic Orange Tester

polyspace-c.exe polyspace-code-prover-nodesktop -lang c

polyspace-cpp.exe polyspace-code-prover-nodesktop -lang
cpp

polyspace-remote-c.exe polyspace-code-prover-nodesktop -lang c
-batch

polyspace-remote-cpp.exe polyspace-code-prover-nodesktop -lang
cpp -batch

polyspace-remote.exe polyspace-code-prover-nodesktop -batch

polyspace-rlI-manager.exe polyspace-server-settings.exe

polyspace-spooler.exe polyspace-job-monitor.exe

polyspace-ver._exe polyspace-code-prover-nodesktop -ver

The binaries to use are located in matlabroot/polyspace/bin.

Support for Visual Studio 2008 to be removed

The Polyspace Add-In for Visual Studio® 2008 is no longer supported and will be removed

in a future release.

Compatibility Considerations

To analyze your Visual Studio projects, use either:

*  The Polyspace Add-in for Visual Studio 2010. See Install Polyspace Add-In for Visual

Studio.
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* The polyspace-configure tool to create a project using your build command. See
Create Project Using Visual Studio Information.

Import Visual Studio project removed

The Tools > Import Visual Studio project has been removed.

To import your project information from Visual Studio, use the Create from build
system option during new project creation. For more information, see Create Project
Using Visual Studio Information.

XML and RTF report formats removed

The formats XML and RTF for report generation are no longer available from R2016a
onwards. If you generated reports using one of these formats, use an alternative format
instead.

For more information, see Output format (C/C++).
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Simplified workflow for project setup and results review with a unified
user interface

In R2015a, the Project and Results Manager perspectives are now unified. You can run
verification and review results without switching between two perspectives.

The major changes are:

* You can start a new verification during your results review. Previously, you started a
new verification only from the Project Manager perspective.

+ After a verification, the result opens automatically. If you are looking at a previous
result when a verification is over, you can load the new result or retain the previous
one on the Results Summary pane. If you retain the previous results, you can later
open the new results from the Project Browser. The new results are highlighted.

* You can have any of the panes open in the unified interface.

Previously, you could open the following panes only in one of the two perspectives.

Project Manager

Results Manager

Project Browser: Set up project.

Configuration: Specify analysis
options for your project.

Output Summary: Monitor progress
of verification.

Run Log: Find detailed information
about a verification.

Results Summary: View Polyspace
results.

Source: View read-only form of
source code color coded with Polyspace
results.

Check Details: View details of a
particular result.

Check Review: Comment on a
particular result.

Variable Access: View global
variables and read/write operations on
them.

Call Hierarchy: View callers and
callees of a function.

Results Properties: Same as Run
Log, but associated with results
instead of a project. This pane has
been removed.




Project Manager

Results Manager

To open the log associated with a
result, with the results open, select
Window > Show/Hide View > Run
Log.

+ Settings: Same information as
Configuration, but associated with
results instead of a project. This pane
has been removed.

To open the configuration associated
with a result, with the results open,
select Window > Show/Hide View >
Configuration.

* Orange Sources: View sources of
orange checks.

+ Sensitivity Context: For a check
that has a different color for different
function calls, view the check color for
each function call.

Review of code complexity metrics and global variable usage in user
interface

“Code Complexity Metrics” on page 3-3
“Global Variables” on page 3-4

Code Complexity Metrics

In R2015a, you can view code complexity metrics in the Polyspace user interface. For
more information, see Code Metrics. Previously, this information was available only in
the Polyspace Metrics web interface.

In the user interface, you can:

Specify a limit for the value of a metric. If the metric value for your source code
exceeds this limit, the metric appears red on the Results Summary pane.
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+ Justify the value of a metric. If a metric value exceeds specified limits and appears
red, you can add a comment with the rationale.

Combining these actions, you can enforce coding standards across your organization. For
more information, see Review Code Metrics.

Reducing the complexity of your code improves code readability, reduces the possibility of
coding errors, and allows more precise Polyspace verification.

Global Variables

In R2015a, you can comment and justify global variable usage on the Results Summary
pane. Previously, you viewed global variable usage on the Variable Access pane, but
could not comment on them.

On the Results Summary pane, global variables are classified into one of the following
categories.

Category Color Meaning

Shared Potentially Orange Global variables
unprotected shared between
multiple tasks

but possibly not
protected from
concurrent access by
the tasks

Protected Green Global variables
shared between
multiple tasks and
protected from
concurrent access by
the tasks

Not shared Used Black Global variables
used in a single task

Unused Gray Global variables
declared but not
used

For more information, see Global Variables.
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For code that you do not intend for multitasking, all variables are nonshared and can be
either used or unused. For code that you intend for multitasking, you can specify tasks
and protections through the analysis options for multitasking. For more information, see
Multitasking.

You can still view the global variables on the Variable Access pane.

* To comment and justify potentially unprotected and unused global variables, use the
Results Summary pane.

+ To find the read and write operations on a global variable, use the Check Details or
Variable Access pane. On the Variable Access pane, you can also see the variable
range and other information.

For more information, see Review Global Variable Usage.

Context-sensitive help for code complexity metrics, MISRA-C:2012, and
custom coding rules

In R2015a, context-sensitive help is available in the user interface for code complexity
metrics, MISRA C:2012 rule violations, and custom coding rule violations.

To access the contextual help, see Getting Help.
For information about these results, see:

* Code Metrics
+ MISRA C:2012 Directives and Rules
*  Custom Coding Rules

Detection of stack pointer dereference outside scope

In R2015a, the Illegally dereferenced pointer check can detect stack pointer
dereference outside scope. Such dereference can happen, for example, when a pointer to
a variable that is local to a function is returned from the function. Because the scope of
the variable is limited to the function, dereferencing the pointer outside the function can
cause undefined behavior.

This enhancement is not available by default. Use the option ~detect-pointer-
escape to detect such dereferences. To provide command-line options in the user
interface:

3-5


http://www.mathworks.com/help/releases/R2015a/codeprover/multitasking.html
http://www.mathworks.com/help/releases/R2015a/codeprover/ug/review-global-variables.html
http://www.mathworks.com/help/releases/R2015a/codeprover/gs/getting-help.html
http://www.mathworks.com/help/releases/R2015a/codeprover/metrics-reference.html
http://www.mathworks.com/help/releases/R2015a/codeprover/misra-c2012-directives-and-rules.html
http://www.mathworks.com/help/releases/R2015a/codeprover/custom-coding-rules.html

R2015a

3-6

1 On the Configuration pane, select Advanced Settings.

2 Enter the option in the Other field.

Before R2015a

R2015a

In the following code, ptr points to ret.
Because the scope of ret is limited to
funcl, when ptr is accessed in func2, the
access 1s illegal. Polyspace Code Prover did
not detect such pointer escapes.

void func2(int *ptr) {
*ptr = 0;
H

int* funcl(void) {
int ret = 0;
return &ret ;
3
void main(void) {
int* ptr = funcl(Q) ;
func2(ptr) ;

In the following code, Polyspace
Code Prover produces a red Illegally
dereferenced pointer check on *ptr.

void func2(int *ptr) {
*ptr = 0;
s

int* funcl(void) {
int ret = 0;
return &ret ;
s
void main(void) {
int* ptr = funcl(Q ;
func2(ptr) ;

The Check Details pane displays a message indicating that ret is accessed outside its

scope.

¥ ID 1: Tllegally dereferenced pointer
Error: pointer is outside its bounds

Pointer is not null,

Pointer may point to variable or field of variable:

This check may be a pathrelated issue, which is not dependent on input values
Dereference of parameter 'ptr' (pointer to int 32, size: 32 bits):

Points to 4 bytes at offset 0 in buffer of 4 bytes, so is within bounds (if memaory is allocated).

'ret’, local to function "funcl'. ret’ is accessed outside its scope.

Review of latest results compared to the last run

In R2015a, you can review only new results compared to the previous run.




If you rerun your verification, the new results are displayed with an asterisk (¥*) against
them on the Results Summary pane. To filter only these new checks, select the New
results box.

If you make changes in your source code, you can use this feature to see only the checks
introduced due to those changes. You can avoid reviewing checks in the source code that
you did not change.

Guidance for reviewing Polyspace Code Prover checks in C code

In R2015a, the context-sensitive help for checks provides guidance about how to review
the check. The help describes:

+ Information available in the software for the check.
* In your source code, how to navigate to the root cause of the check.

+  Common causes of the check.
To open the context-sensitive help for a check:

*  On the Results Summary or Source pane, select the check.

Select the & button.
* Select the link in the section Diagnosing This Check.

This additional guidance is not available for C++-specific checks.

Improvements in search capability in the user interface

In R2015a, the Search pane allows you to search for a string in various panes of the user
interface.

To search for a string in the new user interface:

1 If the Search pane is not visible, open it. Select Window > Show/Hide View >
Search.

2 Enter your string in the search box.

3 From the drop-down list beside the box, select names of panes you want to search.

The Search pane consolidates the search options previously available.
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Isolated ellipsis for variable number of function arguments supported

In R2015a, for C++ code, Polyspace Code Prover supports the ellipsis in the function
definition syntax void foo(...){} to mean variable number of arguments. Previously,
the use of ellipsis in isolation was not supported. You could use only the syntax where the

ellipsis was preceded with other parameters.

Before R2015a

R2015a

In the following code, Polyspace considers
that foo has no arguments. Therefore, it
produces a red Correctness condition
error on the second function call. The
Check Details pane indicates that the
wrong number of arguments were used in
the function call.

void foo(.-.) {
/* Function body */
}

void main() {
foo():
foo(1,2); //Red COR

}

In the following code, Polyspace considers
that foo takes a variable number of
arguments. It does not produce a red
Correctness condition error on the
second function call.

void foo(...) {
/* Function body */

}

void main() {
foo();
foo(1,2); //No COR

}

Improvement in pointer comparisons

In R2015a, Polyspace is more precise on pointer comparisons. In certain cases, if the
software can determine that a pointer comparison is always true or false, it provides that
result. Previously, Polyspace did not check pointer comparisons.

Before R2015a

R2015a

In the following code, Polyspace does not
check the comparison ptr==&invalid.
Therefore, it considers that check can
return either O or 1. In the main function,
it verifies both branches of the i f-else
statement.

#include <stdlib._.h>

In the following code, Polyspace checks
the comparison ptr===&invalid

and determines that it is always true.
Therefore, it considers that the i f test is
redundant and the function check returns
1 only. In the main function, it verifies the




Before R2015a

R2015a

typedef unsigned char
U8 invalid;
#define TEST DISABLED &invalid

us;

U8 check(U8 cnt, U8* ptr)

{
U8 ret=0;
if (ptr == &invalid)
{
ret=1;
}
return ret;
3

void main()

{ U8 isDisabled;
isDisabled = check(1U,TEST_DISABLE
if(isDisabled == 1) {
/* Do not perform test */
}
else {
/* Perform test */
}
3

i T branch and considers the el se branch
as unreachable.

#include <stdlib.h>
typedef unsigned char
U8 invalid;

#define TEST DISABLED &invalid

us;

U8 check(U8 cnt, U8* ptr)

{
U8 ret=0;
if(ptr == &invalid)
{
ret=1;
}

return ret;

}

void main(Q)

{ U8 i1sDisabled;
isDisabled = check(1U,TEST_DISABLE
if(isDisabled == 1) {

/* Do not perform test */
}
else {

/* Perform test */

}

Improvements in coding rules checking

MISRA C:2004 and MISRA AC AGC

Rule Number Effect More Information

Rule 12.6 More results on noncompliant MISRA C:2004 Rules — Chapter
#1T preprocessor directives 12: Expressions
Fewer results for variables cast
to effective Boolean types.

Rule 12.12 Fewer results when converting to |MISRA C:2004 Rules — Chapter
an array of fFloat 12: Expressions

D);
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MISRA C:2012
Rule Number Effect More Information
Rules 10.3 Fewer results on enumeration MISRA C:2012 Rule 10.3

constants when the type of the
constant is a named enumeration
type.

Fewer results on user-defined
effective Boolean types.

Rule 10.4 Fewer results on enumeration MISRA C:2012 Rule 10.4
constants when the type of the
constant is a named enumeration
type.

Fewer results for casts to user-
defined effective Boolean types.

Rule 10.5 Fewer results on enumeration MISRA C:2012 Rule 10.5
constants when the type of the
constant is a named enumeration
type.

Fewer results on user-defined
effective Boolean types.

Rule 12.1 More results on expressions MISRA C:2012 Rule 12.1
with sizeof operator and on
expressions with ? operators.
Fewer results on operators of
the same precedence and in
preprocessing directives.

Rule 14.3 No results for non-controlling MISRA C:2012 Rule 14.3
expressions.

MISRA C++:2008

Rule Number Effect More Information

Rule 5-0-3 Fewer results on enumeration MISRA C++ Rules — Chapter 5

constants when the type of the
constant is the enumeration type.

Rule 6-5-1 Fewer results on compliant vector MISRA C++ Rules — Chapter 6
variable iterators.
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Rule Number Effect More Information

Rule 14-8-2 Fewer results for functions MISRA C++ Rules — Chapter 14
contained in the Files and folders
to ignore (C++) option.

Rule 15-3-2 Fewer results for user-defined MISRA C++ Rules — Chapter 15

return statements after a try
block.

Simplified results infrastructure

Polyspace results folders are reorganized and simplified. Files have been removed,
combined, renamed, or moved. The changes do not affect the results that you see in the
Polyspace environment.

Some important changes and file locations:

* The main results file is now encrypted and renamed ps_results.pscp. You can
view results only in the Polyspace environment.

* The log file, Polyspace_R2015a_project_date-time.log has not changed.

For more information, see Results Folder Contents.

Support for GCC 4.8

Polyspace now supports the GCC 4.8 dialect for C and C++ projects.

To allow GCC 4.8 extensions in your Polyspace Code Prover verification, set Target &
Compiler > Dialect option gnu4.8.

For more information, see Dialect (C) and Dialect (C++).

Polyspace plug-in for Simulink improvements
In R2015a, there are three improvements to the Polyspace Simulink plug-in.
Integration with Simulink projects

You can now save your Polyspace results to a Simulink project. Using this feature, you
can organize and control your Polyspace results alongside your model files and folders.
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To save your results to a Simulink project:

1  Open your Simulink project.
2 From your model, select Code > Polyspace > Options.

3 In the Polyspace parameter configuration tab, select the Save results to Simulink
project option.

For more information, see Save Results to a Simulink Project.

DRS file format changed to XML

By default, the DRS files generated in Simulink are saved in XML.

For more information, see XML File Format for Constraints

If you want to used a customized . txt DRS file, contact customer support.
Back-to-model available when Simulink is closed

In the Polyspace plug-in for Simulink, the back-to-model feature now works even when

your model is closed. When you click a link in your Polyspace results, MATLAB® opens
your Simulink model and highlights the appropriate block.

Note: This feature works only with Simulink R2013b and later.

For more information about the back-to-model feature, see Identify Errors in Simulink
Models.

Polyspace binaries being removed

The following Polyspace binaries will be removed in a future release. The binaries are
located in matlabroot/polyspace/bin. You get a warning if you run them.

Binary name Use instead

polyspace-automatic -orange- From the Polyspace environment, select Tools >
tester.exe Automatic Orange Tester

polyspace-c.exe polyspace-code-prover-nodesktop -lang c
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Binary name

Use instead

polyspace-cpp.exe

polyspace-code-prover-nodesktop -lang
cpp

polyspace-remote-c.exe

polyspace-code-prover-nodesktop -lang c
-batch

polyspace-remote-cpp.exe

polyspace-code-prover-nodesktop -lang
cpp -batch

polyspace-remote.exe

polyspace-code-prover-nodesktop -batch

polyspace-rlI-manager.exe

polyspace-server-settings.exe

polyspace-spooler.exe

polyspace-job-monitor.exe

polyspace-ver.exe

polyspace-code-prover-nodesktop -ver

Import Visual Studio project being removed

The File > Import Visual Studio project will be removed in a future release. Instead,
use the Create from build system option during New Project creation. For more
information, see Trace Visual Studio Build.
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Support for MISRA C:2012

Polyspace can now check your code against MISRA C:2012 directives and coding rules. To
check for MISRA C:2012 coding rule violations:

1
2
3

On the Configuration pane, select Coding Rules.
Select Check MISRA C:2012.

The MISRA C:2012 guidelines have different categories for handwritten and
automatically generated code.

If you want to use the settings for automatically generated code, also select Use
generated code requirements.

For more information about supported rules, see MISRA C:2012 Coding Directives and
Rules.

Improved verification speed

In R2014b, the following two changes improve the verification speed:

Polyspace Code Prover can run the compilation phase of your verification in parallel
on multiple processors. The software detects available processors and uses them to
compile different source files in parallel.

Previously, the software ran post-compilation phases in parallel but compiled the
source files sequentially. Starting in R2014b, the software can use multiple processors
for the entire verification process.

To explicitly specify the number of processors, use the command-line option -max-
processes. For more information, see -max-processes.

Polyspace Code Prover has an improved engine for verification. This engine typically
improves verification speed by 256%. However, in some cases, verification can take the
same amount of time or longer.

Compatibility Considerations

In most cases, you do not see significant change in the number of checks resulting from
the improved engine. If you see a major increase in the number of orange checks, contact
technical support. For more information, see Obtain System Information for Technical
Support.


http://www.mathworks.com/help/releases/R2014b/codeprover/ug/misra-c2012-coding-rules.html
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Support for Mac OS

You can install and run Polyspace on Mac OS X. Polyspace is supported for Mac OS
10.7.4+, 10.8, and 10.9.

You can use Polyspace Metrics on Safari and set up your Mac as a Metrics server.
However, if you restart your Mac machine that is setup as a Metrics server, you must
restart the Polyspace server daemon.

The Automatic Orange Tester is not supported for Mac.

Improved verification precision for non-initialized variables

Polyspace Code Prover performs the following checks for initialization:

*  Non-initialized local variable or NIVL

*  Non-initialized variable or NIV
In R2014b, the following changes appear in these checks.
Read Operations on Structures

When you read structured variables, Polyspace Code Prover performs a check for
initialization. This check helps detect partially initialized and non-initialized structures
earlier in the code.

Prior to R2014b R2014b

*  When you read structured variable, When you read structured variables, a
a check for initialization was not check for initialization occurs. The check
performed. turns:

The checks occurred only when you
read individual fields of a structured
variable, provided the fields themselves
were not structured variables.

+  Green, if all fields of the structure that
are used are initialized. If no field is
used, the check is green by default.

+ Red, if all fields that are used are not
initialized.
*  Orange, if only some fields that are

used are initialized. Following the
check, Polyspace considers that the
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Prior to R2014b

R2014b

uninitialized fields have the full range
of values allowed by their type.

Polyspace considers a field as used if there
1s a read or write operation on the field
anywhere in the code. Polyspace does not
check for initialization of fields that are not
used.

To determine which fields Polyspace
checked for initialization:

1  Select the NIV or NIVL check on the
Results Summary pane or Source
pane.

2 View the message on the Check
Details pane.




Prior to R2014b

R2014b

Example:

typedef struct S {
int a;
int b;

}S;

void funcl(S);
void func2(int);

void main() {
S varsS;
funcl(varS);
func2(varS.a);

}

A check was not performed when the non-
initialized structure varS was read. When
the field a of varS was read, a red NIVL
check appeared.

Example:

typedef struct S {
int a;
int b;

}S;

void funcl(S);
void func2(int);

void main() {
S vars;
funcl(varS);
func2(varS.a);

}

When the non-initialized structure vars is
read, a red NIVL check appears.

For more examples, see:

+ Partially initialized structure — All
used fields initialized

+ Partially initialized structure — Some
used fields initialized

Other Operations

The specification of Non-initialized variable checks has changed for the following
operations. These operations are not commonly used. Therefore, it is likely that these
changes do not affect your Polyspace verification.

Prior to R2014b

R2014b

If you initialized only the high bits of a
variable through a pointer, an orange
check for initialization appeared when the
variable was read.

If you initialize only the high bits of a
variable through a pointer, a green check
for initialization appears when the variable
is read.

If you performed an operation on a C++
object after it was destroyed, a red check
for initialization appeared on the operation.

If you perform an operation on a C++
object after it is destroyed, the check
for initialization has the same color as
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Prior to R2014b R2014b
The check indicated that the object was before the destruction. Polyspace does not
destroyed. introduce a red check on this type of access.

Compatibility Considerations

If you use an earlier version of Polyspace Code Prover, it is possible that you see the
following changes in your results.

* Read operation on structures: You see an increase in the total number of checks.

However, some red or orange NIV or NIVL checks on the fields of structures turn
green. Instead, you see some new red or orange checks on the structures themselves.

*  Other operations:
If you have operations that initialize only the high bits of a variable through a
pointer, you can see a reduction in orange NIV or NIVL checks.

If you have operations that access an object after it is destroyed, you can see a
reduction in red NIV or NIVL checks.

Support for C++11

Polyspace can now fully analyze C++ code that follows the ISO/IEC 14882:2011 standard,
also called C++11.

Use two new analysis options when analyzing C++11 code. On the Target & Compiler
pane, select:

+  C++11 extensions to allow the standard C++11 libraries and functions during your
analysis.

+ Block char 16/32_t types to not allow charl6_t or char32_t types during the
analysis.

For more information, see C++11 Extensions (C++) and Block char16/32_t types (C++).

Context-sensitive help for verification options and checks

In R2014b, contextual help is available for verification options in the Polyspace interface
and its plug-ins. To view the contextual help:


http://www.mathworks.com/help/releases/R2014b/codeprover/ref/c-11-extensions-c.html
http://www.mathworks.com/help/releases/R2014b/codeprover/ref/block-char1632-t-types-c.html

1  Hover your cursor over a verification option in the Configuration pane.
2 Inside the tooltip, select the “More Help” link.

The documentation for that option appears in a dockable window.

Contextual help is available in the Polyspace interface for run-time errors. To view the
contextual help for checks:

1 In the Results Manager perspective, select a run-time error from the results.

. ; (7
Inside the Check Details pane, select "=/,
The documentation for that check appears in a docked window.

For more information, see Getting Help.

Code Editor for editing source files in Polyspace user interface
In R2014b, by default, you can edit your source files inside the Polyspace user interface.

* In the Project Manager perspective, on the Project Browser tree, double-click your
source file.

* In the Results Manager perspective, right-click the Source pane and select Open
Source File.

Your source files appear on a Code Editor tab. On this tab, you can edit your source
files and save them.

To use an external text editor, change your preferences.

1 Select Tools > Preferences.

2 Specify an external editor on the Editors tab.

For more information, see Specify External Text Editor.

Local file-by-file verification

In R2014b, you can verify your source code file by file on your local installation of
Polyspace Code Prover. Each file is verified independently of the other files in your
module. Previously, you performed file-by-file verification only on a remote server. The
verification required:
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* Parallel Computing Toolbox™ on the client side
* MATLAB Distributed Computing Server™ on the server side

For more information on file-by-file verification, see:

*  Run File-by-File Verification
*  Open Results of File-by-File Verification

For information on file-by-file verification in batch mode, see:

*  Run File-by-File Batch Verification
*  Open Results of File-by-File Batch Verification

Simulink plug-in support for custom project files

With the Polyspace plug-in for Simulink, you can now use a project file to specify the
verification options.

On the Polyspace pane of the Configuration Parameters window, with the Use custom
project file option you can enter a path or browse for a . psprj project file.

For more information, see Configure Polyspace Analysis Options.

Targetlink support updated

The Polyspace plug-in for Simulink now supports TargetLink 3.4 and 3.5. Older versions
of TargetLink are not supported.

For more information, see TargetLink Considerations.

AUTOSAR support added

In R2013b, the Polyspace plug-in for Simulink added support for AUTOSAR generated

code with Embedded Coder®. If you use autosar . tlc as your System target file
for code generation, when you run Polyspace, the verification can use the data range
information from AUTOSAR.

The Polyspace verification uses the same default options and parameters as it does for
Embedded Coder.
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http://www.mathworks.com/help/releases/R2014b/codeprover/ug/open-results-of-file-by-file-verification-in-user-interface.html
http://www.mathworks.com/help/releases/R2014b/codeprover/ug/run-file-by-file-remote-verification.html
http://www.mathworks.com/help/releases/R2014b/codeprover/ug/open-results-of-file-by-file-batch-verification.html
http://www.mathworks.com/help/releases/R2014b/codeprover/ug/configuring-polyspace-project.html
http://www.mathworks.com/help/releases/R2014b/codeprover/ug/targetlink-considerations.html

For more information, see Embedded Coder Considerations.

New checks for functions not called

Two new checks in Polyspace Code Prover detect C/C++ functions that are defined but

not called during execution of the code.

Check

Purpose

Function not called

Detects functions that are defined but not
called in the source files.

Function not reachable

Detects functions that are defined but
called only from an unreachable part of the
source.

You can choose to activate these checks using the following options:

* In the user interface, on the Configuration pane, under Check Behavior, select a
value for the option Detect uncalled functions.

+ At the command line, use the option —uncal led-function-checks with an

appropriate argument.

Goal

Option Value

Do not detect uncalled functions.

none

Detect functions that are defined but not
called.

never-called

Detect functions that are defined and called
only from an unreachable part of the code.

called-from-unreachable

Detect all uncalled functions.

all

Default verification level changed

In R2014b, unless you specify a verification level explicitly, Polyspace Code Prover
verification performs two passes on your source code instead of four. For instance:

* In the user interface, on the Output Summary tab, you can see that the verification
continues to Level2. For more passes, on the Configuration pane, under the
Precision node, select a higher Verification level.
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* At the command line, the verification implicitly uses -to pass?2. For more passes,
use the -to option explicitly with a higher pass value.

The default verification is completed in much less time.
For more information, see:

+ Verification level (C)
+ Verification level (C++)

Compatibility Considerations

If you do not specify a verification level explicitly in your polypsace-code-prover-
nodesktop command, your verification runs to Software Safety Analysis Level
2. In most cases, this verification level produces only slightly more orange checks than
Software Safety Analysis Level 4. However, if you see a significant change in
your results, to reproduce your earlier results:

* In the user interface, select Software Safety Analysis Level 4 for
Verification level.

* At the command line, use the option —-to pass4 with the polypsace-code-
prover-nodesktop command.

Improved precision level

In R2014b, certain internal limits have been removed from verification that uses a
Precision level of 3. Because of this improvement, you can use this Precision level
to significantly reduce orange checks, especially for multitasking code that uses shared
variables. However, if you use this level, the verification can take significantly longer.

To set Precision level to 3, do one of the following:

+ In the user interface, on the Configuration pane, select Precision. From the
Precision level drop-down list, select 3.

* At the DOS or UNIX® command prompt, use the flag -03 with the polyspace-
code-prover-nodesktop command.

* At the MATLAB command prompt, use the argument "-03" with the
polyspaceCodeProver function.

For more information, see Precision level (C/C++).


http://www.mathworks.com/help/releases/R2014b/codeprover/ref/verification-level-to.html
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Default mode changed for C++ code verification in user interface

When you create a new Polyspace Code Prover project with C++ as the project language,
the following options are selected in the user interface by default. The options appear on
the Configuration pane under the Code Prover Verification node.

Option Value
Verify Module On
Class all
Functions to call within the specified |[unused
classes

Functions to call unused
Variables to initialize uninit

These options replace the default selection of Verify whole application on the
Polyspace user interface.

If your C++ code does not contain a main function, Polyspace generates a main by default
during verification from the user interface.

For more information on the main generation options, see Provide Context for C++ Code
Verification.

Updated Software Quality Objectives

In R2014b, the Software Quality Objectives or SQOs have been updated to include
MISRA® C++: 2008 coding rule violations.

Using the predefined SQO levels, you can specify quality thresholds for your project or
individual files in your project. With the updated SQOs, you can now specify that your
project must not violate certain MISRA C++ rules.

For more information, see Predefined SQO Levels.

Improved global menu in user interface

The global menu in the Polyspace user interface has been updated. The following table
lists the current location for the existing global menu options.
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Goal Prior to R2014b R2014b
Open the Polyspace Metrics |File > Open Metrics Web |Metrics > Open Metrics
interface in your web Interface

browser.

Upload results from the
Polyspace user interface to
Polyspace Metrics.

File > Upload in
Polyspace Metrics
repository

Metrics > Upload to
Metrics

Update results stored in
Polyspace Metrics with
your review comments and
justifications.

File > Save in Polyspace
Metrics repository

Metrics > Save comments
to Metrics

Generate a report from
results after verification.

Run > Run Report > Run
Report

Reporting > Run Report

Open generated report.

Run > Run Report >
Open Report

Reporting > Open Report

Partition source code into
modules.

Run > Run Modularize

Tools > Run Modularize

Import review comments
from previous verification.

Review > Import

Tools > Import Comments

Specify code generator for
generated code.

Review > Code
Generator Support

Tools > Code Generator
Support

Specify settings that apply
to all Polyspace Code Prover
projects.

Options > Preferences

Tools > Preferences

Specify settings for remote
verification.

Options > Metrics and
Remote Server Settings

Metrics > Metrics and
Remote Server Settings

Improved Project Manager perspective

The following changes have been made in the Project Manager perspective:

* The Progress Monitor tab does not exist anymore. Instead, after you start a
verification, you can view its progress on the OQutput Summary tab.

* Instead of a single progress bar showing all the stages of verification, you can see two
progress bars. The top bar shows progress in the current stage of verification and the
lower bar shows overall progress.




Level2: 0% Elapsed time: 00:00:00
Total: 75%: Total elapsed time: 00:00:17

After verification, you can see the overall time taken. To see the time taken in each

stage of verification, click the (W icon.

In the Project Browser, projects appear sorted in alphabetical order instead of order
of creation.

Changed analysis options

Changes have been made to the following analysis options:

On the Configuration pane, the analysis option Files and folders to ignore has
been moved from Coding Rules Checking to Inputs & Stubbing. The functionality
in Polyspace Code Prover has not changed.

On the Configuration pane, the Interactive option has been removed from the
graphical interface. To use interactive mode, use the —interactive flag at the
command line or in the Advanced Settings > Other text field.

You cannot use batch mode or interactive mode with Verification Level > C/C++
source compliance checking.

To run only to code compliance, run Polyspace Code Prover locally.

To perform batch or interactive verifications, use Software Safety Analysis level 0
or higher.

Improved Results Manager perspective

The following changes have been made in the Results Manager perspective:

On the Source pane, the following code appears in gray:

+  Code deactivated due to conditional compilation. Polyspace assigns a lighter shade
of gray to this code.

+ Code in an unreachable branch. Polyspace assigns a darker shade of gray to this
code.
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For the difference between the two cases, see the code below. To reproduce the
colors, before verification, on the Configuration pane, enter Polyspace= for
Preprocessor definitions.

k4 souree
Dashboard X |test_file.c x
#include <limits.h>
int getVal():

vold main{) {

int a=getVal(),b:

#ifdef Polyspace
b=a*a;

if (k<) I

#elae

#endif

To prioritize your orange check review, use the Show menu on the Results
Summary pane. This menu replaces the previously available methodologies for the
same purpose.

+ To display red, gray, and orange checks likely to be run-time errors, from the
Show menu, select Critical checks. This option replaces the First checks to
review methodology.

* To display all checks, from the Show menu, select All checks. This option
replaces the All checks methodology.

+ The methodologies Methodology for C/C++ > Light and Methodology for C/C+
+ > Moderate have been removed.



+ To create your own subset of orange checks to review, select Tools > Preferences.
On the Review Scope tab, specify the number or percentage of orange checks of
each type to review. The options on this tab replace the options on the Review
Configuration tab.

* To group your checks, use the Group by menu on the Results Summary pane.
To leave your checks ungrouped, instead of List of Checks, select Group by >
None.

To group checks by check color and type, instead of Checks by Family, select
Group by > Family.

To group checks by file and function, instead of Checks by File/Function, select
Group by > File.

* To view the percentage of checks that you have justified, instead of the Review
Statistics pane, use the Justified column on the Results Summary pane. On this
pane:

+ To view the percentage of checks that you justified broken down by color/type,
select Group by > Family.

* To view the percentage of checks that you justified broken down by file/function,
select Group by > File.

Error mode removed from coding rules checking

In R2014b, the Error mode has been removed from coding rules checking. Therefore,
coding rule violations cannot stop a verification.

Compatibility Considerations

For existing coding rules files, rules having the keyword error are treated in the same
way as the keyword warning. For more information on warning, see Format of Custom
Coding Rules File.

Remote launcher and queue manager renamed

Polyspace has renamed the remote launcher and the queue manager.
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Previous name

New Name

More information

polyspace-rlI-manager.exe

polyspace-server-
settings.exe

Only the binary name has
changed. The interface
title, Metrics and Remote
Server Settings, is
unchanged.

polyspace-spooler.exe

polyspace-job-monitor.exe

Queue Manager or Spooler

Job Monitor

The binary and the
interface titles have
changed. Interface labels
have changed in the
Polyspace interface and its
plug-ins.

pslinkfun("queuemanager®)

pslinkfun("jobmonitor*®)

See pslinkfun.

Compatibility Considerations

If you use the old binaries or functions, you receive a warning.

Polyspace binaries being removed

The following Polyspace binaries will be removed in a future release. Unless otherwise
noted, the binaries to use are located in matlabroot/polyspace/bin.

Binary name

What
happens

Use instead

tester.exe

polyspace-automatic -orange-

Warning | From the Polyspace environment, select Tools
> Automatic Orange Tester

polyspace-c.exe

lang c

Warning |polyspace-code-prover-nodesktop

polyspace-cpp.exe

lang cpp

Warning |polyspace-code-prover-nodesktop

polyspace-remote-c.exe

Warning |polyspace-code-prover-nodesktop
lang c -batch

polyspace-remote-cpp.exe

Warning |polyspace-code-prover-nodesktop
lang cpp -batch
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Binary name What  |Use instead
happens
polyspace-remote.exe Warning |polyspace-code-prover-nodesktop -
batch
polyspace-rlI-manager.exe Warning |polyspace-server-settings.exe
polyspace-spooler.exe Warning |polyspace-job-monitor.exe
polyspace-ver.exe Warning |polyspace-code-prover-nodesktop -ver
setup-remote-launcher.exe Warning imatlabroot/toolbox/polyspace /
psdistcomp/bin/setup-polyspace-
cluster

Import Visual Studio project being removed
The File > Import Visual Studio project will be removed in a future release. Instead,

use the Create from build system option during New Project creation. For more
information, see Trace Visual Studio Build.
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Automatic project setup from build systems

In R2014a, you can set up a Polyspace project from build automation scripts that you use
to build your software application. The automatic project setup runs your automation
scripts to determine:
* Source files.
* Includes.
+ Target & Compiler options.
To set up a project from your build automation scripts:
*  On the DOS or UNIX command line: Use the polyspace-configure command. For
more information, see Create Project from DOS and UNIX Command Line.
* In the user interface: When creating a new project, in the Project — Properties
window, select Create from build command. In the following window, enter:
*  The build command that you use.
* The directory from which you run your build command.

Additional options. For more information, see Create Project in User Interface.

Click Iﬂ/. In the Project Browser, you see your new Polyspace project with
the required source files, include folders, and Target & Compiler options.

*  On the MATLAB command line: Use the polyspaceConfigure function. For more
information, see Create Project from MATLAB Command Line.

Support for GNU 4.7 and Microsoft Visual Studio C++ 2012 dialects

Polyspace supports two additional dialects: Microsoft Visual Studio C++ 2012 and GNU®
4.7. If your code uses language extensions from these dialects, specify the corresponding
analysis option in your configuration. From the Target & Compiler > Dialect menu,
select:

* gnu4.7 for GNU 4.7
+ visualll.0 for Microsoft Visual Studio C++ 2012

For more information about these and other supported dialects, see Dialects for C or
Dialects for C++.
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Documentation in Japanese

The Polyspace product, including the documentation, is available in Japanese.

To view the Japanese version of Polyspace Code Prover documentation, go to http://
www.mathworks.co.jp/jp/help/codeprover/. If the documentation appears in English, from
the country list beside the globe icon at the top of the page, select Japan.

Support for additional Coding Rules (MISRA C:2004 Rule 18.2, MISRA C+

+ Rule 5-0-11)

The Polyspace coding rules checker now supports two additional coding rules: MISRA C

18.2 and MISRA C++ 5-0-11.

+ MISRA C 18.2 is a required rule that checks for assignments to overlapping objects.
+ MISRA C++ 5-0-11 is a required rule that checks for the use of the plain char type as
anything other than storage or character values.

* MISRA C++ 5-0-12 is a required rule that checks for the use of the signed and
unsigned char types as anything other than numerical values.

For more information, see MISRA C:2004 Coding Rules or MISRA C++ Coding Rules.

Preferences file moved

In R2014a, the location of the Polyspace preferences file has been changed.

Operating Location before R2014a Location in R2014a

System

Windows %APPDATA%\Polyspace %APPDATA%\MathWorks\MATLAB\R2014a
\Polyspace

Linux® /home/$USER/ .polyspace |/home/$USER/ .matlab/$RELEASE/Polyspace

For more information, see Storage of Polyspace Preferences.

Support for batch analysis security levels

When creating an MDCS server for Polyspace batch analyses, you can now add
additional security levels through the MATLAB Admin Center. Using the Metrics
and Remote Server Settings, the MDCS server is automatically set to security level
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zero. If you want additional security for your server, use the Admin Center button. The
additional security levels require authentication by user name, cluster user name and
password, or network user name and password.

For more information, see MDCS documentation.

Interactive mode for remote verification

In R2014a, you can select an additional Interactive mode for remote verification. In this
mode, when you run Polyspace Code Prover on a cluster, your local computer is tethered
to the cluster through Parallel Computing Toolbox and MATLAB Distributed Computing
Server.

To run verification in this mode

* In the user interface: On the Configuration pane, under Distributed Computing,
select Interactive.

*  On the DOS or UNIX command line, append -interactive to the polyspace-
code-prover-nodesktop command.

*  On the MATLAB command line, add the argument "-interactive” to the
polyspaceCodeProver function.

For more information, see Interactive.

Default text editor

In R2014a, Polyspace uses a default text editor for opening source files. The editor is:

* WordPad in Windows

* viin Linux

You can change the text editor on the Editors tab under Options > Preferences. For

more information, see Specify Text Editor.

Results folder appearance in Project Browser

In R2014a, the results folder appears in a simplified form in the Project Browser.
Instead of a folder containing several files, the result appears as a single file.

*  Format before R2014a:
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=13 Demo_C [(]
1.3 Source
'Ij Include
=3 Module_1
"ﬁ Source
-1 .3 Configuration
El'lj Result
EF'E Result_1 [Verification Completed]

'Iﬁ opticns

' kd|Demo_C.pscp

'|_| MISRA-C-report.xml
|| Custom-rules-report.xml

Format in R2014a:

=3 Demo_C[C]
'ﬁ Source
"ﬁ Include
=13 Module_1
'ﬁ Source
'Ij Cenfiguration
El'lj Result
hd)Result 1 [Verification Completed]

The following table lists the changes in the actions that you can perform on the results
folder.

Action 2013b 2014a
Open results. In the result folder, double- Double-click result file.
click result file with extension
.pscp.
Open analysis options used for |In the result folder, select Right-click result file and select
result. options. Open Configuration.
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Action

2013b

2014a

Open metrics page for batch
analyses if you had used the
analysis option Distributed
Computing > Add to results
repository.

In the result folder, select
Metrics Web Page.

Double-click result file.

If you had used the option
Distributed Computing >
Add to results repository,
double-clicking the results file
for the first time opens the
metrics web page instead of the
Result Manager perspective.

Open results folder in your file
browser.

Navigate to results folder.

To find results folder location,
select Options > Preferences.
View result folder location

on the Project and Results
Folder tab.

Right-click result file and
select Open Folder with File
Manager.

Results Manager improvements

* In R2014a, you can view the extent of a code block on the Source pane by clicking
either its opening or closing brace.
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Dashboard = |135k51.c x| 14 F B
gtatic wvoid initregqulate (wvoid) =~
{

int tmp = 0;
while ({random int({) < 1000}
tmp = orderregulate(): “\[5
Begin CS{): E
tmp = SHR + SHR2 + SHRG:
End C5():
tmp = Get Powerlevel():
Compute TInjection():
} 7* end loopr */f
} -
1 r

| |'¥| Source | [L.]] Data Range Configuration

Note: This action does not highlight the code block if the brace itself is already
highlighted. The opening brace can be highlighted, for instance, if there is an
Unreachable code error on the code block.

In R2014a, the Verification Statistics pane in the Project Manager and the Results
Statistics pane in the Results Manager have been renamed Dashboard.

On the Dashboard, you can obtain an overview of the results in a graphical format.
For more information, see Dashboard.

In R2014a, on the Results Summary pane, you can distinguish between violations of
predefined coding rules such as MISRA C or C++ and custom coding rules.
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The predefined rules are indicated by = .

The custom rules are indicated by * .

In addition, when you click on the Check column header on the Results Summary
pane, the rules are sorted by rule number instead of alphabetically.

+ In R2014a, you can double-click a variable name on the Source pane to highlight all
instances of the variable.

Simplification of coding rules checking

In R2014a, the Error mode has been removed from coding rules checking. This mode
applied only to:

* The option Custom for:

Check MISRA C rules
Check MISRA AC AGC rules
Check MISRA C++ rules
Check JSF C++ rules

* Check custom rules

The following table lists the changes that appear in coding rules checking.

Coding Rules
Feature

2013b

2014a

New file wizard
for custom
coding rules.
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For each coding rule, you can select three
results:

+  Error: Analysis stops if the rule is
violated.

The rule violation is displayed on the
Output Summary tab in the Project
Manager perspective.

+ Warning: Analysis continues even if
the rule is violated.

For each coding rule, you can select
two results:

*  On: Analysis continues even if
the rule is violated.

The rule violation is displayed on
the Results Summary pane in
the Result Manager perspective.

+ Off: Polyspace does not check for
violation of the rule.




Coding Rules
Feature

2013b

2014a

The rule violation is displayed on the
Results Summary pane in the Result
Manager perspective.

+  Off: Polyspace does not check for
violation of the rule.

Format of the
custom coding
rules file.

Each line in the file must have the syntax:

rule off|error|warning #comments

For example:

# MISRA configuration - Projl
10.5 off #don"t check 10.5
17.2 error

17.3 warning

Each line in the file must have the
syntax:

rule off|warning #comments

For example:

# MISRA configuration - Projl
10.5 off #don"t check 10.5
17.2 warning

17.3 warning

Compatibility Considerations

For existing coding rules files that use the keyword error:

+ If you run analysis from the user interface, it will be treated in the same way as the
keyword warning. The verification will not stop even if the rule is violated. The rule
violation will however be reported on the Results Summary pane.

+ If you run analysis from the command line, the verification will stop if the rule is
violated.

Support for Windows 8 and Windows Server 2012

Polyspace supports installation and analysis on Windows Server® 2012 and Windows 8.

For installation instructions, see Installation, Licensing, and Activation.
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Check model configuration automatically before analysis

For the Polyspace Simulink plug-in, the Check configuration feature has been
enhanced to automatically check your model configuration before analysis. In the
Polyspace pane of the Model Configuration options, select:

*+ On, proceed with warnings to automatically check the configuration before
analysis and continue with analysis when only warnings are found.

+ On, stop for warnings to automatically check the configuration before analysis
and stop if warnings are found.

+  OFf to never check the configuration automatically before an analysis.
If the configuration check finds errors, Polyspace always stops the analysis.

For more information about Check configuration, see Check Simulink Model Settings.

Additional back-to-model support for Simulink plug-in

As you click the different links, the corresponding block is highlighted in the
model. Because of internal improvements, the back-to-model feature is more stable.

Additionally, support has been added for Stateflow® charts in Target Link and Linux
operating systems.

For more information about the back-to-model feature, see Identify Errors in Simulink
Models.

Function replacement in Simulink plug-in

The following functions have been replaced in the Simulink plug-in by the function
pslinkfun. These functions be removed in a future release.

Function What Use This Function Instead

Happens?
PolyspaceAnnotation Warning pslinkfun("annotations®,...)
PolySpaceGetTemplateCFGFile Warning pslinkfun(“gettemplate®)
PolySpaceHelp Warning pslinkfun(“help™)
PolySpaceEnableCOMServer Warning pslinkfun(“enablebacktomodel *)
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Function What Use This Function Instead

Happens?
PolySpaceSpooler Warning pslinkfun(®queuemanager®)
PolySpaceViewer Warning pslinkfun( openresults®,...)
PolySpaceSetTemplateCFGFile Warning pslinkfun("settemplate®,...)
PolySpaceConfigure Warning pslinkfun("advancedoptions®)
PolySpaceKillAnalysis Warning pslinkfun("stop™)
PolySpaceMetrics Warning pslinkfun("metrics"®)

Polyspace binaries being removed

The following Polyspace binaries will be removed in a future release:

+ polyspace-automatic-orange-tester.exe
+ polyspace-c.exe

+ polyspace-cpp.-exe

+ polyspace-modularize.exe

+ polyspace-remote-c.exe

+ polyspace-remote-cpp.-exe

+ polyspace-remote.exe

+ polyspace-report-generator.exe

+ polyspace-results-repository.exe
+ polyspace-rl-manager .exe

+ polyspace-spooler.exe

+ polyspace-ver.exe

+ setup-remote-launcher.exe

Improvement of floating point precision
In R2013b, Polyspace improved the precision of floating point representation. Previously,

Polyspace represented the floating point values with intervals, as seen in the tooltips.
Now, Polyspace uses a rounding method.
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For example, the verification represents Float arr = 0.1; as,

* Pre-R2013b, arr = [9.9999E"-2,1.0001E-1].
* Now,arr = 0.1.
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Proven absence of certain run-time errors in C and C++ code

Use Polyspace Code Prover to prove the absence of overflow, divide-by-zero, out-of-
bounds array access, and certain other run-time errors in source code. To verify code,

the software uses formal methods-based abstract interpretation techniques. The code
verification is static. It does not require program execution, code instrumentation, or test
cases. Before compilation and test, you can verify handwritten code, generated code, or a
combination of these two types of code.

Color-coding of run-time errors directly in code
Polyspace Code Prover uses color coding to indicate the status of code elements.

* Green — Proved to never have a run-time error.
* Red — Proved to always have a run-time error.
*  Gray — Proved to be unreachable, which can indicate a functional issue.

* Orange — Unproven, and can have an error.
Errors detected include:

*  Overflows, underflows, divide-by-zero, and other arithmetic errors
*  Out-of-bounds array access and illegally dereferenced pointers

+ Always true/false statement due to dataflow propagation

* Read access operation on uninitialized data

* Dead code

* Accesstonull this pointer (C++)

*  Dynamic errors related to object programming, inheritance, and exception handling
(C++)

*  Uninitialized class members (C++)

* Unsound type conversions

For more information, see Interpret Results.
Calculation of range information for variables, function parameters and
return values

Polyspace Code Prover calculates and displays range information associated with, for
example, variables, function parameters and return values, and operators. The displayed
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range information represents a superset of dynamic values, which the software computes
using static methods.

For more information, see Interpret Results.

Identification of variables exceeding specified range limits

By default, Polyspace Code Prover performs a robustness verification of your code. The
verification proves that the software works under all conditions. As the verification
assumes that all data inputs are set to their full range, almost any operation on these
inputs can produce an overflow.

To prove that your code works in normal conditions, use the Data Range Specification
(DRS) feature to perform contextual verification. You can set constraints on data ranges,
and verify your code within these ranges. The use of DRS can substantially reduce the
number of orange checks in verification results.

You can use DRS to set constraints on:

* Global variables
* Input parameters for user-defined functions called by the main generator

*  Return values for stub functions

For a global variable, if you specify the globalassert mode, the software generates a
warning when the variable exceeds your specified range.

For more information, see Data Range Configuration.

Quality metrics for tracking conformance to software quality objectives

You can define a quality model with reference to coding rule violations, code complexity,
and run-time errors. By observing these metrics, you can track your progress toward
predefined software quality objectives as your code evolves from the first iteration to the
final version.

By confirming the absence of certain run-time errors and measuring the rate of
improvement in code quality, Polyspace Code Prover enables developers, testers, and
project managers to produce, assess, and deliver code that is free of run-time errors.

For more information, see Quality Metrics.
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Web-based dashboard providing code metrics and quality status

Polyspace Code Prover provides Polyspace Metrics, a Web-based dashboard for tracking
submitted verification jobs, reviewing progress, and viewing the quality status of your
code. Polyspace Metrics provides an integrated view of project metrics, displaying code
complexity, coding rule violations, run-time errors, and other code metrics.

For more information, see Quality Metrics.

Guided review-checking process for classifying results and run-time error
status

In the Results Manager perspective, Polyspace Code Prover provides you with several
options to organize your review process.

* You can use review methodologies to specify the number and type of checks displayed
on the Results Summary pane. With each methodology, you review only a subset of
checks.

For example, if you are reviewing verification results for the first time, select First
checks to review. The software displays all red and gray checks but only a subset of
orange checks. These orange checks are the ones most likely to be run-time errors. For
more information, see Review Checks Using Predefined Methodologies.

*  You can group checks by File/Function or Check:

*  Grouping by Check classifies checks by color. Within each color, this grouping
classifies checks by categories related to the origin of the check, such as Control
flow, Data flow, and Numerical.

Grouping by File/Function classifies checks by the file where they originated.
Within each file, this grouping classifies checks by functions where they
originated.

*  For C++ files, you can also group checks by Class. This grouping classifies checks
by the class definition where they originated.

For more information, see Organize Check Review Using Filters and Groups.

* You can filter checks using any of the column information criteria on the Results
Summary pane. For example, you can filter out checks that you have already
justified using the filter icon on the Justified column header. If you have applied
a filter, the column heading changes to indicate that all results are not displayed.
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You can also define custom filters. For more information, see Organize Check Review
Using Filters and Groups.

* You can navigate through the Results Summary pane using the keyboard or Ul
buttons. Both means of navigation respect the grouping, filters, and methodology used
to display results.

Graphical display of variable reads and writes

A Polyspace Code Prover verification generates a data dictionary with information
about global variables and the read and write access operations on these variables. You
can view this information through the Variable Access pane of the Results Manager
perspective.

For more information, see Exploring Results Manager Perspective.

Comparison with R2013a Polyspace products

Polyspace Code Prover is a single product that replaces the following R2013a products:

* Polyspace Client™ for C/C++
*  Polyspace Server™ for C/C++

Polyspace Bug Finder, which is available with the Polyspace Code Prover, incorporates
the following R2013a products:

* Polyspace Model Link™ SL
* Polyspace Model Link TL
* Polyspace UML Link™ RH

For a summary of differences and similarities in remote verification, results review and
other features and options, expand the following:

Remote verification

Category R2013a R2013b
Install: Install:
Products required |* Polyspace Client for C/C++ on + MATLAB, Polyspace Bug Finder,
local computer and Parallel Computing Toolbox on
local computer.
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Category

R2013a

R2013b

Polyspace Server for C/C++ on
network computers, which are
configured as Queue Manager and
CPUs.

MATLAB, Polyspace Bug Finder,
Polyspace Code Prover, and
MATLAB Distributed Computing
Server on head node of computer
cluster. For information about
setting up a cluster, see Install
Products and Choose Cluster
Configuration.

Configuring and
starting services

6-6

On the Polyspace Preferences >
Server Configuration tab:

Under Remote configuration,
specify host computer for Queue
Manager and Polyspace Metrics
server and communication port.

Under Metrics configuration,
specify other settings for
Polyspace Metrics.

On the Polyspace Preferences >
Server Configuration tab:

Under MDCS cluster
configuration, specify computer
for cluster head node, which hosts
the MATLAB job scheduler (MJS).
The MJS replaces the R2013a
Polyspace Queue Manager.

Under Metrics configuration:
* Specify host computer for

Polyspace Metrics server and
communication port.

+ Specify other settings for

Polyspace Metrics.
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Category

R2013a

R2013b

In the Remote Launcher Manager
dialog box:

1 Under Common Settings,
specify Polyspace communication
port, user details, and results
folder for remote verifications.

2 Under Queue Manager
Settings, specify Queue
Manager and CPUs.

3 Under Polyspace Server
Settings, specify available
Polyspace products.

4 To start the Queue Manager and

Polyspace Metrics service, click
Start Daemon.

In the Metrics and Remote Server
Settings dialog box:

1 Under Polyspace Metrics
Settings, specify user details,
Polyspace communication port,
and results folder for remote
verifications.

2 Under Polyspace MDCS
Cluster Security Settings, you
see the following options with
default values:

+ Start the Polyspace MDCE
service — Selected. The mdce
service, which is required to
manage the MdJS, runs on the
MJS host computer and other
nodes of the cluster.

+ MDCE service port — 27350.

+ Use secure communication
— Not selected. Communication
is not encrypted. You may
want to use communication
with security. For information
about MATLAB Distributed
Computing Server cluster
security, see Cluster Security.

3 To start the Polyspace Metrics
and mdce services, click Start
Daemon.

Use the Metrics and Remote Server
Settings dialog box to start and stop
mdce services only if you configure
the MDCS head node as the Polyspace
Metrics server. Otherwise, clear the
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R2013b

Category

R2013a

R2013b

Start the Polyspace MDCE service
check box, and use the MDCS Admin
Center. To open the MDCS Admin
Center, run:

MATLAB_Install/toolbox/distcomp/bin/adminc]
For information about the MDCS
Admin Center, see Cluster Processes
and Profiles.

enter

Running a remote
verification

In the Project Manager perspective:

1 On the Configuration >
Machine Configuration pane,
select the following check boxes:

+ Send to Polyspace Server

+ Add to results repository
— Allows viewing of results
through Polyspace Metrics.

2 On the toolbar, click Run.

The Polyspace client performs code
compilation and coding rule checking
on the local, host computer. Then

the Polyspace client submits the
verification to the Queue Manager on
your network.

In the Project Manager perspective:

1 On the Configuration >
Distributed Computing pane,
select the Batch check box. By
default, the software selects the
Add to results repository,
which enables the generation of
Polyspace Metrics.

2 On the toolbar, click Run.

The Polyspace Code Prover software
performs code compilation and
coding rule checking on the local,
host computer. Then the Parallel
Computing Toolbox client submits
the verification job to the MdJS of the
MATLAB Distributed Computing
Server cluster.

Managing remote
verifications

Use the Queue Manager to monitor
and manage submitted jobs from
Polyspace clients.

On the Web, you can monitor jobs
through Polyspace Metrics. If you
have installed Polyspace Server for C/
C++ on your local computer, through
Polyspace Metrics, you can open the
Queue Manager .

Use the Queue Manager to monitor
and manage jobs submitted through
Parallel Computing Toolbox clients.
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Category

R2013a

R2013b

Accessing results of
remote verifications

When you run a verification on a
Polyspace server, the Polyspace
software automatically downloads the
results to your local, client computer.
You can view the results in the
Results Manager perspective.

In addition, you can use the Queue
Manager to download results of
verifications submitted from other
Polyspace clients.

On the Web, use Polyspace Metrics

to view verification results stored

in results repository. If Polyspace
Client for C/C++ is installed on your
local computer, you can download
verification results. For example,

in Polyspace Metrics, clicking a cell
value in the Run-Time Checks view
opens the corresponding verification
results in the Results Manager.

On the Web, use Polyspace Metrics to
view verification results. If Polyspace
Bug Finder is installed on your

local computer, you can download
verification results. For example, in
Polyspace Metrics, clicking a Project
cell in the Runs view opens the
corresponding verification results in
the Results Manager.

Results review

Category

R2013a

R2013b

Results Explorer

Available. Allows navigation
through checks by the file and
function where they occur.

To view, select Window >
Show/Hide View > Results
Explorer.

Removed. To navigate through
checks by file and function, on
Results Summary pane, from
the drop-down menu, select
File/Function.

Filters on the Results
Summary pane

Filters appear as icons on the
Results Summary pane. You
can filter by:

*  Run-time error category

*  Coding rules violated

You can filter by the information
in all the columns of the
Results Summary pane. In
addition to existing filters,

the new filtering capabilities
extend to the file, function and
line number where the checks




R2013b

Category

R2013a

R2013b

+  Check color

+  Check justification
+  Check classification
+  Check status

appear. You can also define your
own filters.

The filters appear as the < icon
on each column header. To apply
a filter using the information in
a column:

1 Place your cursor on the
column header. The filter
icon appears.

2 Click the filter icon and
from the context menu,
clear the All box. Select the
appropriate boxes to see the
corresponding checks.

For more information, see
Organize Check Review Using
Filters and Groups.

Code Coverage Metrics

In the Results Explorer
view, the software displays two
metrics for the project:

* unp — Number of
unreachable functions as
a ratio of total number of
functions

+ cov — Percentage of
elementary operations
covered by verification

The unreachable procedures
are marked gray in the Results
Explorer view.

The new Results Statistics
pane displays the code coverage
metrics through the Code
covered by verification
column graph.

To see a list of unreachable
procedures, click this column
graph.

For more information, see
Results Statistics.
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Other features

Product Feature R2013a R2013b
Installation Separate installation Polyspace Code Prover
process for Polyspace software installed during
products MATLAB installation
process.
Project On host, for example, On host, using Polyspace
configuration using Polyspace Client |Code Prover software.

Polyspace Client and
Server for C/C++

for C/C++ software.

Local verification

On host, run Polyspace
Client for C/C++
verification.

Review results in
Results Manager.

On host, run Polyspace
Code Prover verification.

Review results in Results
Manager.

Export of review
comments to
Excel®, and Excel
report generation

Supported

Not supported.

Line command

polyspace-c ...

polyspace-cpp --.

polyspace-code-
prover-nodesktop ...

Project project _name.cfg project name.psprj
configuration file

extension

Results file results name.rte results _name.pscp
extension

Configuration Available Replaced by

> Machine Configuration >
Configuration Distributed Computing
pane pane.

Configuration > |Available Renamed Configuration

Post Verification
pane

> Advanced Settings

goto blocks

Not supported

Supported
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R2013b

Product Feature R2013a R2013b
Run verifications Supported Not supported, produces a
from multiple license error -4, 0.
Polyspace
environments
Non-official Available in Renamed Other and
options field Configuration moved to Configuration
> Machine > Advanced Settings
Configuration pane pane
Polyspace Model Link |Default includes Includes specific to the |Generic includes for C and
SL and TL target specified. C++. These includes are

6-12

target independent.

Running a Code > Polyspace Code > Polyspace >
verification > Polyspace for Verify Code Generated
Embedded Coder/ for
Target Link
+  Selected Subsystem
+ Verify Generated - Model
Code
) Referenced Model
+ Verify Generated )
Model Reference + Selected Target Link
Code Subsystem
Also right-clicking Also right-clicking on a
on a subsystem and subsystem and sel.ectlng
selecting Polyspace Polyspace > Verify
> Polyspace for Code Generated for >
Embedded Coder/ Selected Subsystem/
Target Link Selected Target Link
Subsystem
Product Mode Not available. Choose between Code
Prover or Bug Finder
depending on the type of
analysis you want to run.
Settings Available. Called Available. Called Settings

Verification Settings
from

from. Functionality the
same.




Product

Feature

R2013a

R2013b

Open results

Option Open Project
Manager and Results
Manager opened

the Polyspace Project
Manager.

Option Open results
automatically after
verification opens
Polyspace Metrics (batch
verifications) or Polyspace
Results Manager (local
verifications).

Polyspace plug-in for
Visual Studio 2010

Support for C++11
features

Partial support.

Added support for:

Lambda functions

+  Rvalue references
for *this and
initialization of class
objects by rvalues

+  Decltype

+ Auto keyword for
multi-declarator auto
and trailing return
types

Static assert

*  Nullptr
+  Extended friend
declarations

Local and unnamed
types as template
arguments

Options

Product

Option

R2013a

R2013b

-code-metrics

Available. Not selected
by default.

Removed. Code
complexity metrics
computed by default.
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R2013b

Product Option R2013a R2013b
-dialect Available. Default unchanged,
but new value gnu4 .6
available for C and C++.
-max-processes Specify through Specify from command
Machine line, or through

Polyspace Client and
Server for C/C++

Configuration >
Number of processes
for multiple CPU
core systems or
command line .

Advanced Settings >
Other.

-allow-language-
extensions

Available. Selected by
default.

Removed. By default,
software supports subset
of common C language
constructs and extended
keywords defined by

the C99 standard or
supported by many
compilers.

-enum-type-
definition

Available with three
values. First value
called defined-by-
standard.

Available with three
values.

For C, first value
renamed signed-int.

For C++, first value
renamed auto-
signed-int-first.
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Product Option R2013a R2013b
Polyspace Model Link |-scalar- Available. Not selected |Default.
SL and TL overflows- by default.

behavior wrap-
around

This option identifies
generated code from
blocks with saturation
enabled.

However, this option
might lead to a loss of
precision. For models
without saturation, you
can choose to remove
this option.

-ignore-constant-
overflows

Available. Not selected
by default.

Default.
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